Dodge SRT Forum banner

1 - 3 of 3 Posts

·
Registered
2005 srt4
Joined
·
10 Posts
Discussion Starter #1
i would really love some advice on what i should do about my missfire it is back on cylinder 4 i have done the plugs, wires, coil pack, fuel pump and injectors , and the crank sensor and rectifier and the pcm and the iats and intake mani gasket and the tb gasket i am at a loss i have went over the ground wires and i have done a compression test and leak down boost leak and vacuum is good im starting to think its a bad wire or something in the harness if i just open the tb with my hand it holds idle just fine but if i use the gas pedal it gets a wierd stutter and i can unplug the number 4 injector and or the plug wire and it dont change anything but i put them back on it cleans up and it will idle fine and if i drive it it will stutter and eventually clean up and go the it will break up a lil and then do it again so it is almost like number 4 is just falling in and out and idk what else to do so if anyone could point me in the right direction or show me where i can find a wiring diagram so i can try to figure it out it woud be really awesome ! thanks in advance!
 

·
Premium Member
Joined
·
4,712 Posts
Any CELs to go along with the issues you're having?
 

·
Registered
2005 srt4
Joined
·
10 Posts
Discussion Starter #3
Any CELs to go along with the issues you're having?
The only one I'm getting now is injector circut open occasionally I get a over boost code when I go from the 93 tune with my dsp to the stock tune but that's because of my agp wga
 
1 - 3 of 3 Posts
Top