Dodge SRT Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
696 Posts
Discussion Starter · #1 ·
For some reason or other the throttle on my car got stuck open. That in itself made for a very interesting experience and quite a long story.

But for the guys I told I'd be at the track today... I can't :(
 

·
Premium Member
Joined
·
1,603 Posts
dmagro said:
For some reason or other the throttle on my car got stuck open. That in itself made for a very interesting experience and quite a long story.

But for the guys I told I'd be at the track today... I can't :(
what was it...stuck cable? IAC valve???
 

·
Registered
Joined
·
696 Posts
Discussion Starter · #3 ·
They haven't had a chance to look at it yet.

From what I could tell it was just the cable that kept getting stuck and causing the pedal to feel odd. Unfortunately, full throttle when you don't even have your foot on the accelerator can do bad things when you're driving to work! :stab:

I'm no expert in cars and mechanics but I've got a bad feeling about the car's status, namely the engine. :grimrippe
 

·
Premium Member
Joined
·
1,603 Posts
I hope it is fine. A stuck cable? Sure it is not the floor mat? I have had that happen before...

Hopefully it all turns out for the better.
I just got back from the track with animalcracker...I think he stripped a mm bolt.

I finally cut my 13.6. Highest trap was 107.28mph. I did get busted on a red light (.419)....so me and my shallow staging self got thrown off for the remainder of the night. I did run consistent low 13.7's.
 

·
Registered
Joined
·
696 Posts
Discussion Starter · #5 ·
4trs said:
I hope it is fine. A stuck cable? Sure it is not the floor mat? I have had that happen before...

Hopefully it all turns out for the better.
I just got back from the track with animalcracker...I think he stripped a mm bolt.

I finally cut my 13.6. Highest trap was 107.28mph. I did get busted on a red light (.419)....so me and my shallow staging self got thrown off for the remainder of the night. I did run consistent low 13.7's.
Wasn't the floor mat, I checked that while the car had a mind of it's own, haha.

I should know more by tomorrow.

Glad to see you're in the 13.6's now, and you trapped a bit higher than my car, which makes sense since you've got the exhaust on.

I'm so dissapointed I couldn't go, I was really looking forward to finally getting a run in after the exhaust and t-bolt clamps on one of the intercooler hoses (the one I had overtightened the stock clamp which caused it to be a tad loose).
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top