Dodge SRT Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
11,360 Posts
Discussion Starter · #1 ·
running 17 wheels with 225/45/17 tires...

when i have even 1 passenger, and take a hard turn, the tire rubs... when i have 3 other people in the car, it will rub on every small turn..


mopar coilovers are not that low if left to the stop ring.. what gives?




-- also run 2 filled motor mounts from deyeme racing (tranny mount is stock though) if that has anything else to add to the equation



was thinking of buying tires 225/40, but that would offset the speedo etc..


let me know what else it could be, i dont like the rubbing :crybaby:
 

·
Registered
Joined
·
11,360 Posts
Discussion Starter · #3 ·
i was hoping against having to get it aligned again... but if just rolling the fenders doesnt do it, then i will.. more - camber then


thanks man :thumbsup:




funny some people with eibachs (lower then mine) dont rub.. oh well, im sure its on my part that needs to be corrected
 

·
Registered
Joined
·
3,231 Posts
Freak said:
i thought you were the guy in your sig, yella shirt. perhaps that would explain it..lmao
:rofl: :rofl: :rofl: :rofl:
 

·
Registered
Joined
·
11,360 Posts
Discussion Starter · #10 ·
had it with my last wheels, which were exel daytonas... they were a different offset then current 42 wheels
 

·
Registered
Joined
·
11,329 Posts
petar7408 said:
running 17 wheels with 225/45/17 tires...

when i have even 1 passenger, and take a hard turn, the tire rubs... when i have 3 other people in the car, it will rub on every small turn..


mopar coilovers are not that low if left to the stop ring.. what gives?
ooo... after that statement, I'm re-thinking the 225/45/17s I was gonna get for my R/T that has Mopar Stage 2 CO's...lowered at the stop ring... shoooot... :-(
 

·
Registered
Joined
·
11,329 Posts
zephrus21 said:
you need a 40mm offset to get good clearence on a 7" rim with mopar coilovers.
No to hijack, but, I'm gonna take my kit off (rejoice) and lower it more... but I've got 17 x 7.5" and I *THINK* 35 mm offset, they stick out like mofo's... this is gonna be bad, isn't it? (the rubbin issue) :-( :-( (my smilies dont load/work for some reason) oh man....
 

·
Registered
Joined
·
910 Posts
Hmmmm.I have the stage 3 coilovers set at their stock height,all 3 filled mounts from Deyeme Racing,using 225/50/16 while autoxing and my tires don't rub.Maybe your tires are rubbing because of body roll.Have you upgraded the sway bars?I did,with a 26mm front and 22mm rear.My wheels have a 38 offset,btw.
 

·
Registered
Joined
·
11,360 Posts
Discussion Starter · #16 ·
yea, must be offset then??


Janet, my car wont rub, when im by myself.. its the extra weight of even a single passenger that makes it rub...
 

·
Registered
Joined
·
11,360 Posts
Discussion Starter · #17 ·
starkie, you have 42 offset wheels too! and the same setup, hey i didnt know...

please take your wife out for a quick spin and see if that makes it rub in the slightest... on some good quick turns

let me know if possible.. and get back to me!! thanks
 

·
Registered
Joined
·
11,360 Posts
Discussion Starter · #18 ·
my camber is prob off... it was aligned to spec when the CO were installed...

i'll ride with you :thumbsup: ... not many want to ride with me LOL

i think it rubs in the front.. you see and outline on the front tires, very noticable..


and tex doesnt work at speed merchant anymore, i heard he went back to school..
 
1 - 20 of 22 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top