Dodge SRT Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
8,271 Posts
Discussion Starter · #1 ·
My car is relatively stock. I added the Mopar BOV yesterday. I made sure everything is completely tight. I'm not quite sure what exactly i'm supposed to be boosting stock but for some reason i can barely hit 10-12psi at WOT!?! I'll hit 14psi when i'm in 4th gear in low rpms and hit WOT. Is something wrong? I keep hearing everyone talking about 15-16psi all day. I had my PCM replaced at 900 miles about 2 weeks ago. I dont know. I just think this car should be hitting 15 psi w/out a problem. It feels way too sluggish. :buah:

After i hit 5k rpms it drops. I can never seem to get a steady boost. Could it be my driving perhaps? Please, somebody help me out. I really dont want to take this car back to the moronic service techs at my local dealer. They had to drive my car to another dealer to get it fixed. :flame:

This is my first turbo car but I've been around WRX's and Evo's alot so i learn as i go. Any info will be most appreciated. :readclose
 

·
SRTforums Youngun
Joined
·
959 Posts
You shouldnt be able to pull 15 psi all the way to redline. The wastegate spring is too weak to do that. You should hit full boost at like 5500 rpm then feel it drop down. A AGP WGA)wastegate actuator) will help tons. People hold 16 staright to redline.
 

·
Registered
Joined
·
2,063 Posts
If you're on the stock pcm, then this sounds normal. Not too many S0 cars will hit 15 psi on a regular basis.
 

·
Registered
Joined
·
2,063 Posts
Let me restate that, below 2500rpm in 4th or 5th, 15psi is very obtainable. But there is no way that S0 will still be at 15psi above 5000rpm. With S1 I couldn't even do that.

Also, as you may know, weather plays a big factor when it comes to how much boost you're making.
 

·
Registered
Joined
·
792 Posts
Did you remove the negative battery cable when you installed the BOV? Because if you did then you reset the PCM, and that may be causing your boost to do strange things while it's re-learning. Give it another day or two and see if it goes back to normal.
 

·
Registered
Joined
·
3,121 Posts
the ppl hitting 15 PSI on Stage 0 are simply boost spikes....then it drops to 12-13psi almost instantly and then 10 PSI after about 5300 RPM.

:)
 

·
Registered
Joined
·
2,063 Posts
That sounds about right to me. Then again, I'm no exert, but that's what my car would boost too when I was stock.
 

·
Premium Member
Joined
·
4,869 Posts
I ahve stage 0 for now and I hit and hold 15...dropping to 14 maybe 13 at redline. I do however notice that I am able to hold better after I put on the Ed hard pipes. The pipes didnt make it jump alot, but I was able to hold about 1 - 1 1/2 more PSI with the pipes. Maybe its the weather here being hot and humid all the time is reason it will hit and hold 15 and drop barely. Today it was in 90's with 100% humidity......
 

·
Registered
Joined
·
181 Posts
Your car is fine, theres nothing wrong with it at all! Our cars stock hit anywhere from 10 -12 psi wot. it very normal at lower rmps to hit around 13-14 psi dropping to 10 -12 psi at redline. As far as everyone saying they hit 14-17 psi stock are full of it, unless there boost gauge is fucked up, or they have an after market wastegate, or stage 1 , or 2. so dont worry about your car having problems.
 

·
Registered
Joined
·
1,022 Posts
my stage0 '04 used to spike to 15 most of the time and in 4th and 5th it would spike above 15. A couple days ago it would not spike above 13 and hold only like 10lbs in any gear. I tightend up the hose clamps on the intercooler piping and it is gaining a lil bit back. I havn't got to the hardest to reach hose clamps (under turbo and on passenger side intercooler pipe. Now in 2nd it will spike and hold 11-12 and 3rd and 4th around 13lbs.

So Stage0 can consistantly hit 15lbs and boost leaks can drag you down from there.
 

·
Registered
Joined
·
8,271 Posts
Discussion Starter · #18 ·
It's good to know that my car is pretty normal. I'm really looking forward to ordering a stage 2 kit but the wait and demand for it is unbelievable! For now, i'm ordering a CAI set-up and most likely go w/ a AGP WGA. Most owners seem to be pleased w/ it. To answer one's question, i never disconnected the battery when i installed the BOV. I'll keep updates on what i've installed and how my car is doing. Thanks for the help guys.
 

·
Registered
Joined
·
99 Posts
I have stage 0 and in warm weather my car will hold 15 psi and spike to 18 below 2700 RPM in fifth gear. In slightly cooler weather (75 and below) i hold 14 psi and spike to 17 ish in fifth gear. From what i've heard that is pretty good for a near stock car but i think this is a result of my heavy right foot because before a got 2000 miles on my car i would only hold 11-13 psi stock and spike 15. you have to remember that our cars have very active ECU's that like to change boost depending on many different conditions ( Air temp, air density, oil temp, rpm, A/C knob position and gear selection) so anyone of these things could be either more then ideal or less then ideal and cause dramaticly different boost schedules.
 

·
Registered
Joined
·
1,022 Posts
good point.....I stressing over it too much. Alot of the time the boost comes on different and it makes me think there is a problem. I needs to chill.
 
1 - 20 of 25 Posts
Top