Dodge SRT Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
about three days ago i put had greddy profec b installed as well as a forge motorsports wga. i noticed yesterday that whenever i try to accelerate, my boost, even though the day before i was only holding 15 lbs, goes through the roof. So i cant even accelerate because my boost will probably do some damage. Its like my boost controller has no control. We even un plugged the boost controller and rerouted it back to stock. It does the same thing. What could be wrong?
 

·
Registered
Joined
·
741 Posts
reset pcm and check for leaks.

Perc
 

·
Registered
Joined
·
975 Posts
You have somthing hooked up wrong. When you switched it back to stock, you must have forgotten somthin. On the other hand, your WGA could not be workin properly or its broke all together. Check the WGA.
 

·
Registered
Joined
·
4,527 Posts
srtwhat said:
about three days ago i put had greddy profec b installed as well as a forge motorsports wga. i noticed yesterday that whenever i try to accelerate, my boost, even though the day before i was only holding 15 lbs, goes through the roof. So i cant even accelerate because my boost will probably do some damage. Its like my boost controller has no control. We even un plugged the boost controller and rerouted it back to stock. It does the same thing. What could be wrong?
Boost pressure is not reaching the wga to move the arm. Trace back from your wga and check for broken or disconected hoses. Also check to make sure your wga arm didnt break.
 
1 - 4 of 4 Posts
Top