Dodge SRT Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
728 Posts
Discussion Starter · #1 · (Edited)
While changing the oil for the first time today I noticed this. From the genius wiring job I could tell it wasn't OEM. It in the upper pressure pipe. The car has an AGP direct fit FMIC with and AGP upper and lower charge pipe. I thought it might be the AIT sensor, bit that's supposed to be in the intake. Someone has suggest there are two sensors, one in the intake and one in the upper pressure pipe.

If it is an AIT sensor, can I delete it without any ill effects? If not, what the hell is it?
 

Attachments

·
Premium Member
Joined
·
180 Posts
Hmmm, I'm guessing this sensor is on the cold side pipe. This would lead me to believe that this is indeed another AIT sensor. The stock pcm reads the one on the intake pipe before the turbo, however taking a reading in this location will actually provide a better reading since the the air has been pressurized by the turbo and cooled by the intercooler. Do you have a sensor for AIT in your car?
 

·
Registered
Joined
·
728 Posts
Discussion Starter · #3 ·
Yep, it's on the cold side. No, the previous owner had a K&N ram air intake installed. Seems he deleted the the black line and the AIT while he was at it.
 

·
Registered
Joined
·
294 Posts
The srt has two IAT sensors.. one on the intake a.k.a AAT or Ambient Air Temp sensor, reads air going before the turbo.. If unplugged or taken out it may give cel code P0073.. The other is on the cold side as shown in the picture, if that one is unplugged or the wires to the sensor are not making proper contact then it may throw cell code P0113.. And to answer your question you need both..
 

·
Registered
Joined
·
728 Posts
Discussion Starter · #5 ·
Well, the one in the intake is gone and it's not throwing any codes and it runs fine. I have no problem leaving the other one in. I'm going to get a JMB upper and I don't think it's got a bung for this. I'm just concerned about that.
 

·
Registered
Joined
·
294 Posts
I have that same sensor on my cold side pipe and it wasn't making good contact on the wires so it threw a cel P0113..
 

·
Registered
Joined
·
759 Posts
While changing the oil for the first time today I noticed this. From the genius wiring job I could tell it wasn't OEM. It in the upper pressure pipe. The car has an AGP direct fit FMIC with and AGP upper and lower charge pipe. I thought it might be the AIT sensor, bit that's supposed to be in the intake. Someone has suggest there are two sensors, one in the intake and one in the upper pressure pipe.

If it is an AIT sensor, can I delete it without any ill effects? If not, what the hell is it?
Looks like someone used one of these... I was tempted to buy 2 of them so they wouldn't blow out. Blow Off Valves & Adapters - AGP Upper Hard Pipe (UHP) Screw In Temp Sensor 03-05 Neon SRT4
 

·
Registered
Joined
·
728 Posts
Discussion Starter · #13 ·
Oh!

I see what you're saying. It's not in the intake. He's probably just tucked it out of the way. Alright. I'll find that and just get the intake with the hole for the AIT. And then I'll get under there and fix that crap wiring job on the charge sensor.

Thanks for all the help.
 

·
Registered
Joined
·
2 Posts
Hey guys im looking for the exact same sensor. Just bought an srt4 and noticed it was missing but the brass fitting is still there and wires are cut. Anyone know were i can get a threaded ait sensor like this?
 

·
Premium Member
Joined
·
4,797 Posts
Hey guys im looking for the exact same sensor. Just bought an srt4 and noticed it was missing but the brass fitting is still there and wires are cut. Anyone know were i can get a threaded ait sensor like this?
 
1 - 15 of 15 Posts
Top