Dodge SRT Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 · (Edited)
I know this subject has been beat around so many times but I am just do lazy to look for it so I will just ask.
First off I have a hallman pro rx bost controller and the spring mod( I have an agp wga in the mail ). When the outside air is cool my car spikes about 19 and kind of losses a little power( I know just turn down the boost) but it falls to about 18 then to 17 and then it drops to about 13 or 14 at redline. However when it was hot today it would run about 17 or 18 psi and drop to 13 or 14 at redline. I have only had this on one day so its not like I have been driving around like this. What I need to know is what is causing the boost spike and is it nomal. And also is it safe to run that much boost on stage 0. And finally what do you people suggest I run the boost at on a stage 0 and still have a reliable and sound car. Please help me understand. This is my first turbo car and all of this is new so please go easy on me.
 

·
Registered
Joined
·
2,638 Posts
I would say that you should spike at about 17 psi, and then dropping to 14-15 psi at redline. Seems to be a safe level. I would be careful about spiking any more than that on a completely stock vehicle. Just my 2 cents.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #3 ·
Thanks, more replys from everybody are welcome. Post away. The more information I see the better I understand and then I wont have to keep asking questions like this one all the time. Thanks again.
 

·
Registered
Joined
·
798 Posts
Personally I don't get guys who spend money on boost controllers and WGA even before buying STAGE I. Pretty much you are going to run boost levels that are very similar to STAGE I but not nearly as safe. Just buy STAGE I and do the spring mod and you can very safely run 17 pounds to redline probally 18. AFTER you get STAGE I then get your boost controllers WGA and so on. That is just my 2 cents. Plus if you want a real kick in the pants put on a BDJ's exhaust. All that boost needs to go somewhere after it has gone through the motor and that tiny stock exhaust is killing you.
 

·
Registered
Joined
·
1,138 Posts
well i have th edtip mod and agp wga and have it set to hold 16psi to redline..max safely you can go is around 17psi..
 

·
Registered
Joined
·
475 Posts
SRT-154 said:
I know this subject has been beat around so many times but I am just do lazy to look for it so I will just ask.
First off I have a hallman pro rx bost controller and the spring mod( I have an agp wga in the mail ). When the outside air is cool my car spikes about 19 and kind of losses a little power( I know just turn down the boost) but it falls to about 18 then to 17 and then it drops to about 13 or 14 at redline. However when it was hot today it would run about 17 or 18 psi and drop to 13 or 14 at redline. I have only had this on one day so its not like I have been driving around like this. What I need to know is what is causing the boost spike and is it nomal. And also is it safe to run that much boost on stage 0. And finally what do you people suggest I run the boost at on a stage 0 and still have a reliable and sound car. Please help me understand. This is my first turbo car and all of this is new so please go easy on me.
Please in the future try to utilize the search function do not be " too lazy to look" . We have enough threads on the forum covering this topic already...
 

·
Premium Member
Joined
·
4,568 Posts
acesrt04 said:
Personally I don't get guys who spend money on boost controllers and WGA even before buying STAGE I. Pretty much you are going to run boost levels that are very similar to STAGE I but not nearly as safe. Just buy STAGE I and do the spring mod and you can very safely run 17 pounds to redline probally 18. AFTER you get STAGE I then get your boost controllers WGA and so on. That is just my 2 cents. Plus if you want a real kick in the pants put on a BDJ's exhaust. All that boost needs to go somewhere after it has gone through the motor and that tiny stock exhaust is killing you.
for a 2004 that is completely FALSE. The 03s had serious problems upgrading the boost due to the small injectors. I safely run stage 0 at 16psi fade to 14psi with just a waste gate and no boost controller.


NBSRT04 said:
well i have th edtip mod and agp wga and have it set to hold 16psi to redline..max safely you can go is around 17psi..
16psi @ redline is pushing it on a stage 0. A quick spike to around 19psi is the highest you should go...then a 17psi midrange and a 15psi reading at redline. Any more and you're playing with fire.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #8 ·
Hades said:
Please in the future try to utilize the search function do not be " too lazy to look" . We have enough threads on the forum covering this topic already...
Well I havnt been on hear in a long time and I didnt realize that there was a search until I had already posted this or I would have used it. I was just looking through the pages got to about 10 and realized that there was like 45 pages and said forget it. Sorry for the too lazy to look comment but it was just easier to ask then look through 45 pages of threads.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #9 ·
N0sferatU said:
16psi @ redline is pushing it on a stage 0. A quick spike to around 19psi is the highest you should go...then a 17psi midrange and a 15psi reading at redline. Any more and you're playing with fire.
This is what my car was doing only droping to about 14 at redline and I had a chech engine light come on today about two miles down the road and i didnt even get on it today.
 

·
Registered
Joined
·
5,834 Posts
spiking to 20psi and dropping to 15.5 @ redline is safe, i have proved this over and over on a wideband.
 

·
Registered
Joined
·
1,138 Posts
oh ya i also have an 04 so i have the 577 injectors
 

·
Premium Member
Joined
·
4,568 Posts
SRT-154 said:
This is what my car was doing only droping to about 14 at redline and I had a chech engine light come on today about two miles down the road and i didnt even get on it today.
plug the red line going into the TB. Goodbye check engine light. I've never had mine come on. :cool: Had the WGA on since late july.
 
1 - 12 of 12 Posts
Top