Dodge SRT Forum banner

21941 - 21960 of 21999 Posts

·
Registered
Joined
·
11,995 Posts
Drove it today finally, after doing all that work to it.
Sweet angels on high, I forgot how much FUN it is when it's all working right.
NO more vibrations what so ever; I didn't realize just how much those axles were affecting it.
Got my pops burbles bangs and barks back on the exhaust again, and no more annoying drone at highway speeds.
Got some funky smells right now, but i'm betting that's just the assembly lube/anti-seize on all exhaust bolts cooking off.
 

·
Registered
Joined
·
11,995 Posts
... and the wheels came off the bus, partially because i'm a FUCKING MORON.

noticed a leak on the garage floor. ATF. figured out it's coming from the driver's side of the trans where the axle goes in. guess it's not in enough.
pulled wheel, pulled axle nut, whacked it a few times, then a few more, then a few more. not going in any deeper.
then I tried to put the nut back on... I fucked up the threads on the end of the brand new shaft.
2 hours later, carefully using a cutoff wheel as a grinder, and a triangle file, I got back to clean enough threads to get the nut back on correctly.

hoping it seated better, and it's not the seal in the trans, as getting it back out could be... interesting.
 

·
Registered
Joined
·
11,995 Posts
got a decent little hour long-ish drive in now, with a bunch of highway. lots more stinky smoke coming off the car when I got to my destination, but none after I got home.
 

·
Registered
Joined
·
11,995 Posts
put cardboard under it when I got back earlier. checked it before I left tonight... no drips. so, at least I guess it's now seated all the way and not leaking? I'll keep an eye on it.
 

·
Registered
Joined
·
4,337 Posts
Get a smoker and find the leak, could be the solenoid too.

Sent from my SM-G988U using Tapatalk
Thanks.
New lockable gas cap coming today from Modern.
If that doesn't fix it, then I'll get a smoker.
Any suggestions about where to connect smoker for testing? Procedure?
Thinking the Blue line may be a start but it's a long way back to the fuel tank.
I'll leave the solenoid until last since they don't usually fail from what I've read here.
I'm not sure where to get a MOPAR replacement solenoid.
 

·
Registered
Joined
·
606 Posts
Thanks.
New lockable gas cap coming today from Modern.
If that doesn't fix it, then I'll get a smoker.
Any suggestions about where to connect smoker for testing? Procedure?
Thinking the Blue line may be a start but it's a long way back to the fuel tank.
I'll leave the solenoid until last since they don't usually fail from what I've read here.
I'm not sure where to get a MOPAR replacement solenoid.
i would put it in the evap service port. its back on the firewall kinda behind the battery

Sent from my SM-G988U using Tapatalk
 

·
Registered
Joined
·
606 Posts
Thanks.
New lockable gas cap coming today from Modern.
If that doesn't fix it, then I'll get a smoker.
Any suggestions about where to connect smoker for testing? Procedure?
Thinking the Blue line may be a start but it's a long way back to the fuel tank.
I'll leave the solenoid until last since they don't usually fail from what I've read here.
I'm not sure where to get a MOPAR replacement solenoid.
make sure its not a bad fitting. those valve dont regularly go bad, and its the same unit thats in every ram, neon, van from the era. you can get one from rock auto, or modern.

Sent from my SM-G988U using Tapatalk
 

·
Super Moderator
Joined
·
15,855 Posts
put cardboard under it when I got back earlier. checked it before I left tonight... no drips. so, at least I guess it's now seated all the way and not leaking? I'll keep an eye on it.
Damn Sota, didn't know you were doing a bunch of work too. I've got my thread going over in the SRT4 Drivetrain section lol.

Hoping to have my new clutch here by next Thursday, and if I'm diligent, maybe rolling by Friday. Can't say really "back on the road" though, with everything I'm working on she'll need a good alignment for sure.
 

·
Registered
Joined
·
11,995 Posts
Ain't the only car i'm working on.
Stratus finally exploded the oil pressure sender, after it'd been leaking/malfunctioning for like 3 years. :D
Job is done, but now I can't find the damn key.

Next up is the Jeep; driver's rear caliper is seizing up.
 

·
Registered
Joined
·
4,337 Posts
04/28/2021 127,012
Problem seems to be solved.
No more P0440's (so far) since installing the new Mopar OEM Locking Gas Cap today!
Will monitor for a few more days before declaring victory.
Then I can reinstall the performance parts again and have some fun!

EDIT
NOPE. PROBLEM NOT SOLVED.
5/5/2021 127,082 Still on STOCK PCM, MAP, TIP, Injectors
P0440-GENERAL EVAP SYSTEM FAILURE even with the new lockable gas cap.
Cleared P0440 with the Aeroforce ScanPro.
It was a HOT day (95*F) and the car sat for a little while at the bank before restart.
So I think the pressure in the fuel tank may have risen a bit due to the ambient temp.

The P0440 is such a general code with no other codes to point at a potential culprit.
Considering a full Smoke Test if I can get the solenoids to activate (thanks Baby Viper for the diags).
But I'll just replace the NVLD first since that is a lot easier to get at (passenger rear wheel).
 

·
Super Moderator
Joined
·
15,855 Posts
So...

The transmission mount inserts

I thought I wouldn't have to worry about grinding away those 4 tiny metal nubs. Yah, that's not going to be an option lol. While not as tight as the lower control arms poly bushings, the trans inserts are going to be interesting. I'll probably have my dremel out tomorrow zipping away at the nubs.
 

·
Registered
Joined
·
606 Posts
So...

The transmission mount inserts

I thought I wouldn't have to worry about grinding away those 4 tiny metal nubs. Yah, that's not going to be an option lol. While not as tight as the lower control arms poly bushings, the trans inserts are going to be interesting. I'll probably have my dremel out tomorrow zipping away at the nubs.
I thought the tranny mount insert.. kinda slid in.

Sent from my SM-G988U using Tapatalk
 

·
Registered
Joined
·
11,995 Posts
you're reminding me... need to poke my head under the car and make sure the gender neutral shift juice isn't still leaking.
 

·
Super Moderator
Joined
·
15,855 Posts
I thought the tranny mount insert.. kinda slid in.

Sent from my SM-G988U using Tapatalk
I'm talking about getting it back into the car, the insert itself went in fairly easy, had to jimmy it a bit with my biggest screwdriver because the mount had settled about a quarter inch or so, but a little dish soap and hot water goes a long way.
 
21941 - 21960 of 21999 Posts
Top