Dodge SRT Forum banner

21761 - 21780 of 21820 Posts

·
Registered
Joined
·
6,950 Posts
Changed the passenger side axle but there's still some popping. Probably the ball joint. Whatever. I've been down this road with my neon before. Lol
145943
 

·
Registered
Joined
·
7,523 Posts
Found out from personal experience that fuel line is not good to run a water line for the turbo...I have a custom line setup because of the non turbo block I used on the rebuild. Anyway, easy fix after searching for 3/8 heater hose.

Then I finally replaced my fogs thanks to my daughter giving me new ones for fathers day. Pic attached
 

Attachments

·
Registered
Joined
·
6,950 Posts
Replaced passenger side ball joint.
Thinking I might need bushings again (been about 6 years).
Also the car has 188,000 miles and still going strong!
 

·
Registered
Joined
·
4,744 Posts
New clutch finally went into the press car, along with all stock parts aside from the forged AGP shift fork. Waiting on a new strut, bump stop, etc. as the rear passenger mount is basically fused to the assembly with rust, and needs to be replaced.

The silver '4 just runs flawlessly. Oil pressure light keeps dinging on the occasional start, so it's still on the list to be replaced... eventually.
 

·
Registered
2005 srt4
Joined
·
31 Posts
Just finished my engine rebuild. Replace/ changed; DCR windage tray, DCR strap kit, DCR hi-fliw oil pump, manly rods, JE .020 over pistons (stock compression), new water pump, gates timing belt, MPX adjustable can gears, DCR oil pressure modifier, 4IN intake, PTE 5857 Turbo rebuild, DCR 1-3-5 gear extender, DCR oil catch and coolant over flow combo, and today had to replace ASD fuse, which blew while trying to test drive the car.
 

Attachments

·
Registered
2005 srt4
Joined
·
31 Posts
Just finished my engine rebuild. Replace/ changed; DCR windage tray, DCR strap kit, DCR hi-fliw oil pump, manly rods, JE .020 over pistons (stock compression), new water pump, gates timing belt, MPX adjustable can gears, DCR oil pressure modifier, 4IN intake, PTE 5857 Turbo rebuild, DCR 1-3-5 gear extender, DCR oil catch and coolant over flow combo, and today had to replace ASD fuse, which blew while trying to test drive the car.
Forgot about shift fork and TOB, mishimoto radiator and fan shroud.
 

·
Registered
Joined
·
2,849 Posts
Replaced passenger side ball joint.
Thinking I might need bushings again (been about 6 years).
Also the car has 188,000 miles and still going strong!
Hey I had to replace my intermediate shaft due to the bearing being worn out. I replaced the passenter axle but still had slop/pop coming from somewhere. I replaced the intermediate shaft at like 160,000 miles and it solved half the problem. Also turned out to be worn out AGP motor mount and trans mount bushings. Posted pics about it on here while back. My ball joints were replaced with NAPA units at 80,000 miles.
 

·
Registered
Joined
·
516 Posts
Replaced my power steering high pressure switch. I also removed my fuel pump rewire mod. I had it in there for 10 years. I'm stock so I see no real benefit for my car.
 

·
Registered
Joined
·
4 Posts
hey everyone new here, working on finishing the last touches on my 05, stock motor, s256 rs big turbo kit, with base tune by dave trojan, still have a lot of leaks and turbo doesnt whistle and need have new exhaust to install as well
 

·
Registered
Joined
·
3 Posts
Hey guys I recently purchased some AGP 1200cc-1400cc fuel injectors, AGP fuel return line kit, Walbro 450 fuel pump, and boomba fuel rail gonna be installing all this soon 😍💪🏽💪🏽
 

·
Registered
Joined
·
2,849 Posts
Hey guys I recently purchased some AGP 1200cc-1400cc fuel injectors, AGP fuel return line kit, Walbro 450 fuel pump, and boomba fuel rail gonna be installing all this soon 😍💪🏽💪🏽
Buy the extended hose that grabs from deeper in the tank. The pump is shorter in length so if you install the 450 or 500 in the stock canister you have essentially raised the level from where you're pulling from and could cavitate the pump. I just did the BNX and the corvette FPR/Regulator thing so it's fresh in my mind.
 

·
Registered
Joined
·
6,950 Posts
Hey I had to replace my intermediate shaft due to the bearing being worn out. I replaced the passenter axle but still had slop/pop coming from somewhere. I replaced the intermediate shaft at like 160,000 miles and it solved half the problem. Also turned out to be worn out AGP motor mount and trans mount bushings. Posted pics about it on here while back. My ball joints were replaced with NAPA units at 80,000 miles.
I haven't replaced the intermediate shaft so that could be the problem (or one of them). All of the mounts are fine to my knowledge. Thanks
 
21761 - 21780 of 21820 Posts
Top