Dodge SRT Forum banner

21481 - 21500 of 21566 Posts

·
Premium Member
Joined
·
3,395 Posts


I picked up a set of stock wheels locally for pretty cheap. They are rough up close, but look good from 10ft away. Haha they only had two with “good tires” so for now the drag radials are still up front.

I did get around to installing new rod ends on my “nacho” rear control arms. The old ones were very worn and sloppy and were making a lot of noise. The new ones completely took care of that. Car is in desperate need of an alignment now more than ever!
 

·
Registered
Joined
·
6,486 Posts
Replaced my passenger side axle yesterday. That fixed the 3rd gear wobble acceleration issue ($60 from Advance Auto after 20% discount). 181,500 miles on the odometer.
 

·
Registered
Joined
·
3,880 Posts
Treated her to an expensive clutch replacement $1750!
I don't think that price is so bad if it includes everything.
The last time I had my clutch replaced was in 2014.
Here's what I paid:

03-25-2014 to 03-28-2014 107,898 miles
SBC Stage 3 Clutch Real Tune $ 535.00
AGP Forged Clutch Fork Modern $ 208.00
Clutch Pivot Ball Modern $ 14.99
Clutch Pivot Fork BOOT & CLIP Modern $ 12.99
Flexplate and 12 bolts Antioch DOdge $ 184.02
Install (including trans fluid) 5-Star, Concord $ 602.72
Total $1557.72

So far so good, I've put about 19K trouble free miles on this clutch.

I'm disabled with a spina bifida which was fused in 1967 when I was 15 but nerve damage during that caused paralysis of my left leg and foot but I can walk kinda OK.
So I'm not able to handle lifting the rather heavy transmission we have in our SRT-4's, even with a decent Harbor Freight Transmission Jack.
And besides, I've got more that enough money to pay for the cost of a clutch job as long as it's done properly, which it was
 

·
Registered
Joined
·
5,929 Posts
I paid to have work done I was capable of doing before (motor refresh).....ended up with more problems than I started with. From that time on; it's all in house because people are criminals and that's too much money to donate without a tax deduction at the end of the year.

Sometimes it's not about the $$....you just can't trust certain things to people in my experience. Mechanics are some of the biggest consumer criminals on earth
 

·
Registered
Joined
·
5,359 Posts
I didn’t even need the clutch is my point. It still had a bit of life left on it (see pic in other thread they gave me the old parts), it had no problems propelling the car, they told me that the clutch itself was squeaking and not the clutch pedal (the reason I brought it in to them in the first place) I’ve started a Charge back through Amex. ....Oh yeah, my clutch pedal is squeaking again now. (I guess they didn’t lube it up properly when I brought it back the other day)
 

·
Registered
Joined
·
6,486 Posts
After a 3d gear pull yesterday the idle started to hang and it's running a little rough. Fix one thing, and break another! Lol (sigh)
I was hoping a vacuum line had just popped off but they look in tact.
Let me know if I miss something:
TPS or IAC (both replaced a couple years ago)
Plugs were replaced within past year.
Wires and coil pack are due for replacement.
Intake manifold gasket is 5 or 6 years old.
Turbo seems to hold normal boost.
 

·
Registered
Joined
·
845 Posts
I didn’t even need the clutch is my point. It still had a bit of life left on it (see pic in other thread they gave me the old parts), it had no problems propelling the car, they told me that the clutch itself was squeaking and not the clutch pedal (the reason I brought it in to them in the first place) I’ve started a Charge back through Amex. ....Oh yeah, my clutch pedal is squeaking again now. (I guess they didn’t lube it up properly when I brought it back the other day)
We'll that is crooked!
 

·
Registered
Joined
·
3,880 Posts
After a 3d gear pull yesterday the idle started to hang and it's running a little rough. Fix one thing, and break another! Lol (sigh)
I was hoping a vacuum line had just popped off but they look in tact.
Let me know if I miss something:
TPS or IAC (both replaced a couple years ago)
Plugs were replaced within past year.
Wires and coil pack are due for replacement.
Intake manifold gasket is 5 or 6 years old.
Turbo seems to hold normal boost.
Maybe a PCM reset would help?
 

·
Registered
Joined
·
6,486 Posts
Removed TPS and IAC, and they looked fine from the outside. IAC spring worked and the inside of the TPS turned & had tension.
When I remove the plug from the IAC though the idle didn't change. I don't know if that's a good test. Did throw a (508?) code though. haha

It's driveable, but runs a little rough, and the idle is high when I let off the gas. Maybe a boost leak test is in order.

https://youtu.be/XR8_R21OWuo

 

·
Registered
Joined
·
5,359 Posts
After a 3d gear pull yesterday the idle started to hang and it's running a little rough. Fix one thing, and break another! Lol (sigh)
I was hoping a vacuum line had just popped off but they look in tact.
Let me know if I miss something:
TPS or IAC (both replaced a couple years ago)
Plugs were replaced within past year.
Wires and coil pack are due for replacement.
Intake manifold gasket is 5 or 6 years old.
Turbo seems to hold normal boost.
Maybe a PCM reset would help?
. Zip tie all vacuum lines 👍 is it possible there is a leak on one?
 

·
Registered
Joined
·
6,486 Posts
. Zip tie all vacuum lines 👍 is it possible there is a leak on one?
All lines are zip tied. It is possible that there is a leak in one, but hearing the engine is now pointing me more towards a bad spark plug, injector, coil pack, etc. because it's a consistent rhythm.
 

·
Registered
Joined
·
6,486 Posts
Ordered Idle Air Control Valve, free next day delivery from Autozone (and $10 off code!).
The high idle and fact that it wants to maintain RPM at any speed makes me think that's the issue.
I'll find out tomorrow!
 

·
Registered
Joined
·
5,623 Posts
Removed TPS and IAC, and they looked fine from the outside. IAC spring worked and the inside of the TPS turned & had tension.
When I remove the plug from the IAC though the idle didn't change. I don't know if that's a good test. Did throw a (508?) code though. haha

It's driveable, but runs a little rough, and the idle is high when I let off the gas. Maybe a boost leak test is in order.

https://youtu.be/XR8_R21OWuo

Yikes that sounds horrible.

I hear a hissing noise. Do a boost leak test before you throw parts at it.
 

·
Registered
Joined
·
6,486 Posts
Yikes that sounds horrible.

I hear a hissing noise. Do a boost leak test before you throw parts at it.
The new IAC valve didn't fix it :-(
I did check the vacuum lines but haven't done a leak test.
Thinking it could be the intake manifold gasket.
Symptoms that really stand out:
Engine running rough
Max boost around 5 lbs
RPM stays same for a few seconds when letting off gas

Update:. Definitely that gasket! I sprayed carb cleaner over on the right side and it nearly died. Lol
 
21481 - 21500 of 21566 Posts
Top