Dodge SRT Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2,063 Posts
Discussion Starter · #1 ·
Here's my problem, I got the dealership to install my agp wga because I couldn't get the heat shield off myself, but they installed the wga wrong :flame: The dealership even supposedly called agp for install help. I wouldn't get full boost until 5000rpm. Now I want to rectify this, but I need some help, I'm kinda lost as to what to do.

Here is how the lines are hooked up.

The green line from the turbo was connected to solenoid 2

The wga was connected to the mbc

the mbc was hooked up to solenoid 2

Now it looks like there are 3 plugs in the solenoid, one is already capped. I know that I have to cap off the green line, but what else do I have to do? Some pics of someones engine bay would be greatly appreciated.
 

·
Registered
Joined
·
1,826 Posts
can't stop spinning said:
Here's my problem, I got the dealership to install my agp wga because I couldn't get the heat shield off myself, but they installed the wga wrong :flame: The dealership even supposedly called agp for install help. I wouldn't get full boost until 5000rpm. Now I want to rectify this, but I need some help, I'm kinda lost as to what to do.

Here is how the lines are hooked up.

The green line from the turbo was connected to solenoid 2

The wga was connected to the mbc

the mbc was hooked up to solenoid 2

Now it looks like there are 3 plugs in the solenoid, one is already capped. I know that I have to cap off the green line, but what else do I have to do? Some pics of someones engine bay would be greatly appreciated.
Well first off, let me say you must have one hell of a friendly dealership if they installed that wga for you. geez.
Anways, i think your best bet is forget the solenoids. Run a line from that back of the turbo (from where the green line USED to be connected too) and run that to your MBC. Then, from the MBC run a line to the WGA. Adjust the WGA and MBC as neccessary. i'm currently running this setup and it's great. :ninja:
 

·
Registered
Joined
·
2,063 Posts
Discussion Starter · #3 ·
Thanks for the input, i'll have to try it.

And yes I go to a pretty good dealership, they'll even keep your warrenty if you have S2.
 

·
Registered
Joined
·
802 Posts
i am currently running similar setup the reason u r seeing funny boost is because the pcm still has control of boost. do as the above post states and you should be fine. back of turbo to MBC, MBC to WGA and your good to go. and by the way cap the redline from your pressure pipe so you dont get CEL's
 
1 - 4 of 4 Posts
Top