Dodge SRT Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
173 Posts
Discussion Starter · #1 ·
Is this normal? I installed both at the same time. It is a AGP WGA and Mopar BOV. I am getting about 12-13 psi of boost with wastegate only. Boost controller is turned completely down. The car stumbles and surges around 1800-2500 rpms. It feels like it is going to die then picks up the pace. I have tried dialing more boost in with the boost controller and the problem still exists. I turned the boost controller completely down until I can get this problem figured out. It is a 2004 stage 0.
 

·
Registered
Joined
·
1,771 Posts
should deffinately go get it tuned on a dyno and make sure ur af is running not to rich or lean, but also how many miles cause i think replacing ur spark plugs helps this...
 

·
Registered
Joined
·
2,166 Posts
Is it part throttle?

Problems like this are what you get when you go that route. You'll just have to tune until it's acceptable to you.
 

·
Registered
Joined
·
173 Posts
Discussion Starter · #4 ·
Yeah it's at part throttle and the car only has 2500 miles on it. Don't think it's the plugs. I imagine it is a little rich. I still get black soot on exhaust tips even with catch can. I have Crane wires, K&N stock replacement, 180 stat, and the other mods listed above. Other than that it is stock.

JCX- Are you saying to adjust on the wga (raise boost) until this problem goes away?
 

·
Registered
Joined
·
173 Posts
Discussion Starter · #5 ·
I went ahead and turned the boost up a little on the wga. I will go drive it in a little while and let you know what happens. Please still respond to my post before this one so I can get your opinion. Thanks.
 

·
Registered
Joined
·
2,166 Posts
My point was that part throttle surging is a known issue with the aftermarket WGA's, you probably can't get rid of it entirely. I am no expert at tuning them whatsoever so I can't offer specific advice. What you should do is check around to see how other's have setup their WGA successfully.
 
1 - 6 of 6 Posts
Top