Dodge SRT Forum banner
1 - 20 of 23 Posts

·
Premium Member (Lifetime), 2011 Calendar Car
Joined
·
12,252 Posts
Discussion Starter · #1 ·
Decided to go to the track tonight, my first time drag racing ever. The weather was beautiful, ~60 and sunny. Only mod is Mopar BOV. Pretty sure there are no leaks because i spike 16PSI and hold like 12PSI to redline. Front tires deflated to ~29lbs.

I'm not sure how to decode the timeslip, so any help would be appreciated...

Here are the times... :rofl:

1st run: Nervous as hell, staged way too deep (shut off prestage light), got way too excited and STALLED on the line :deadcow:
R/T = .894
60 = 13.136
330 = 17.459
1/8 = 20.669
MPH = 154.599 MPH ????
1000 = 23.348
1/4 E.T. = 25.748
MPH = 96.540
Against a lightly modded civic hatch, he ran a 14.571 @ 95.899 (score 0/1)

2nd run. Against a 2000-something Mustang GT. Bogged the launch like a mo-fo
R/T = .626
60 = 2.718
330 = 6.740
1/8 = 9.928
MPH = 156.550 ????
1000 = 12.532
1/4 E.T. = 14.892
MPH = 98.067 ** Best Trap ** :thumbsup:

He only ran a 14.844 @ 94.602, after i recovered from the horrible launch i cought up to him, he red lighted so i won! (score 1/1)

3rd run. Old man in a loud muscle-car era car. It was a chevy something-or-other with a 200 something motor. I Spun the tires on the launch pretty bad, through 1st and most of 2nd
R/T = 1.011
60 = 2.514
330 = 6.596
1/8 = 9.821
MPH = 154.927 ????
1000 = 12.446
1/4 E.T. = 14.834
MPH = 96.405

He was actually trying and only ran a 15.616 @ 87.275 (score 2/3)

4th run. my buddy just picked up a used evo...but he doesn't know how to launch/drive it yet... :tongue: This was my best launch, reving to about 2250-2500 and lots of wheel hop
R/T = .591
60 = 2.485 ** Best 60 foot ** :thumbsup:
330 = 6.526
1/8 = 9.722
MPH = 156.194
1000 = 12.330
1/4 E.T. = 14.693 ** Best ET ** :thumbsup:
MPH = 97.875

PJ and his Evo ran a 16.306 @ 90.822...once he learns how to drive it'll be more interesting (score 3/4)

5th and last run..agains a really intimading heavly modded V8-something. His exhaust was loud enough to vibrate my car... :wah?!: So what did i do? freaked out and stalled on the line. this was my best stage as i actually shallow staged the car almost perfect.
R/T = .894
60 = 7.435
330 = 11.517
1/8 = 14.732
MPH = 155.401
1000 = 17.355
1/4 E.T. = 19.732
MPH = 97.301

he ran a 12.953 @ 106.601 (score 4/5)


So all in all it was a learning experience. From what i can tell i really just need to work on my launches, as i didnt miss a shift all night. I was shifting at about 5800 - 6000 RPM in each gear, hitting 4th near the end of the run. I can't figure out why they say my 1/8th speed is so high...obviously thats wrong. But yeah, any tips/suggestions/analsyses/etc. would be REALLY appreciated.

Also, shout outs to Mark and friends...very cool guys i met at the track. Mark was running a de-spoilered Stock SRT at about 14.0 - 14.1 all night.

Definately going next week. :2thumbsup
 

·
Registered
Joined
·
2,518 Posts
Woo, sounds like fun. What part of Cleveland are you from? Did you run at Norwalk?

Never been to the track. I'd do worse ;) You'll probably be calmer and more at ease next time. Sounds like it was fun.
 

·
Premium Member (Lifetime), 2011 Calendar Car
Joined
·
12,252 Posts
Discussion Starter · #3 ·
I went to Thompson, its off of 90E near chardon (i think)...wasn't too bad, 10 bucks for as many runs as you could get in. The time trials, which was what i did, lasted from 5:15ish to 8:00ish. Then they were going to do class racing and elimination. I figured 5 beatings on my SRT was enough for one night, and i didn't want to get my ass handed to me if i ran another 20 sec pass. But i definately reccomend it, it was really fun.
 

·
Administrator
Joined
·
39,605 Posts
damn, stalling TWICE?!?!?!?!?! best find a back road and practice launching. The only time I have stalled the car was when I was starting from 2nd (rolling at like 1mph) and didn't give it enough gas and enough slip to get the car up to about 7mph (idle speed in 2nd gear). just pushed the clutch in, started her up, dropped to first and got going again.


anyone wanna take bets on how long it will be until these videos show up on the forums?
 

·
Premium Member (Lifetime), 2011 Calendar Car
Joined
·
12,252 Posts
Discussion Starter · #6 ·
stowaway said:
anyone wanna take bets on how long it will be until these videos show up on the forums?
LOL yeah...but hey at least i can say i beat an EVO :rofl:
 

·
Registered
Joined
·
526 Posts
Keep practicing those launches, you ran about the same times I did my first time, 2nd time at the track I ran a best of 14.335 and thats the last time I went. If you go again try turning the radio on low volume. Kinda makes it feel like you're on a street waiting for the light to turn green.
 

·
Premium Member (Lifetime), 2011 Calendar Car
Joined
·
12,252 Posts
Discussion Starter · #9 ·
2004BlackSRT4 said:
If you go again try turning the radio on low volume. Kinda makes it feel like you're on a street waiting for the light to turn green.
Yeah i thought about that after my last run...the silence was kinda killing me...
 

·
Registered
Joined
·
1,979 Posts
congrats on the first time at the strip!!! it truly is a sport, u gotta practice. my first run ever was a 15.8...a month later i ran a 14.017 @ 100mph, so practice is all it takes. I'm goin today and hoping to hit a 13.9. I gotta remember to drop my tire pressure!
Good luck with the runs...
 

·
Premium Member (Lifetime), 2011 Calendar Car
Joined
·
12,252 Posts
Discussion Starter · #15 ·
KrazyK said:
Dont come cryin when you break something. You sound like your 16 how old are you?
Oh i was being sarcastic. I'm 20. My dad's a DC tech so he does all my service...so i dont think getting a claim denyed is in my future. I pay my own insurance, gas, and payment...i respect this car.
 

·
Premium Member (Lifetime), 2011 Calendar Car
Joined
·
12,252 Posts
Discussion Starter · #17 ·
BlackSRT4GUY said:
maybe you shift too late.......i notice on the dynos, the powerband drops at 5500, so thats where i always shift....
Good idea, i'll try that next time
 

·
Registered
Joined
·
462 Posts
Not too bad, being at the track really messes with your nerves the 1st time.

I just did my 1st run at the track a couple weeks ago. I pulled a blazing 15.1xx my 1st run, my r/t was terrible (well over a second), I remember seeing the green and thinking, "damn, I think I need to go now" :rofl:

My second run was 14.226, with a 60' of 2.217. I can't wait to get back to the track again :eveilgrin I'd really like a 14.0 :rockon:
 

·
Registered
Joined
·
6,869 Posts
wow, you cut a 2.4 60 foot and thats your best? rev to 1500 and feather the shit out of the clutch.
 

·
Registered
Joined
·
235 Posts
First run I ever did was a 14.9, best that night after about 10 runs was a 14.4. Second night worst was a 14.6 with a best of 14.11. Then last thursday I ran a worst of 14.01 and best of 13.89. I'm getting a lot better/more consistant. Didn't get a yellow slip until eliminations when I redlighted my first run...

I have also witnessed a WRX, (first-timer) run a 16.3. He wouldn't race me after that embarrasment and disappeared before I got a chance to try it.
 
1 - 20 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top