Dodge SRT Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
2,343 Posts
Discussion Starter #1
Hey, im about to go out to the track, and I had a leak because this vacuum cap was not sealing good. Instead of fixing the cap I would like to get rid of this device if i do not need it. Is it a check valve?, whats the direction of flow? NOTE: I do have a line hooked up to the open port which goes to my throttle body. If its a check vavle id rather just get a generic checkvalve so I dont have to cap off the 3rd port. Thanks!

 

·
Registered
Joined
·
2,343 Posts
Discussion Starter #2
distinctdev said:
Hey, im about to go out to the track, and I had a leak because this vacuum cap was not sealing good. Instead of fixing the cap I would like to get rid of this device if i do not need it. Is it a check valve?, whats the direction of flow? NOTE: I do have a line hooked up to the open port which goes to my throttle body. If its a check vavle id rather just get a generic checkvalve so I dont have to cap off the 3rd port. Thanks!

SOLVED......
OK guys i found out what it is, I pulled it off, Its a check valve, The 2 green ports are where boost would be stoped, the connected port in the picture would then only see vaccum and not boost. ill probably replace this with a ptperfomance check valve. Now whats really got me wondering, is since the leak was coming from there the vacuum cap is, that means these check valves are failing at 15psi. May be a good mod to replace these

:thumbsup:
 

·
Registered
Joined
·
2,079 Posts
hercfe said:
wow! where in the sam hill is that in the engine bay?
Mine is next to the brake master cylinder. I had to zip tie it yesterday since it was leaking during my boost leak test.

Yes, I replaced my all 5 of my worm clamps with T-bolt. Then I did a boost leak test. T-bolt owns all.
 

·
Premium Member
Joined
·
3,246 Posts
has anybody just cap that off from the vacuum system? i have seen someone do it and wanted to know if that is a good idea.
 

·
Registered
Joined
·
1,721 Posts
bump!
 

·
Registered
Joined
·
12,239 Posts
Dude if im not mistaken doesent that go to your brake booster. And of you cap it off you wont have power brakes. I could be wrong but im feeling quite confidant about that.
 

·
Registered
Joined
·
6,282 Posts
That's the line that feeds the "Ludicrous Speed" option.
 

·
Registered
Joined
·
3,195 Posts
bump for some good info on this one, i'm using the top nipple to feed my water injection pressure switch. maybe this is not a good spot? i was going to throw a regular t in there too, now i'm wondering if thats not a good idea
 

·
Registered
Joined
·
402 Posts
dansrt4 said:
Dude if im not mistaken doesent that go to your brake booster. And of you cap it off you wont have power brakes. I could be wrong but im feeling quite confidant about that.
I have to agree that definitely looks like the brake booster. That could be dangerous I would get that back on it's home, and zip tie it down.
 

·
Registered
Joined
·
6,282 Posts
Yes guys, It is the brake booster line. Just zip tie it, I zip tied mine a year ago.
 

·
Registered
Joined
·
12,239 Posts
srt4fun80 said:
bump for some good info on this one, i'm using the top nipple to feed my water injection pressure switch. maybe this is not a good spot? i was going to throw a regular t in there too, now i'm wondering if thats not a good idea
I would tee from TB so it has a more consistant vac signal
 

·
Registered
Joined
·
3,195 Posts
thanks dan, i agree and have been planning on doing it that way. just at the time of install i had that nipple capped and figured mine aswell use it. but i'm do for some reconfiguration of lines as i've been adding so much stuff. so that will be on the to do list. thanks for the insight ;)
 

·
Premium Member
Joined
·
3,246 Posts
srt4fun80 said:
bump for some good info on this one, i'm using the top nipple to feed my water injection pressure switch. maybe this is not a good spot? i was going to throw a regular t in there too, now i'm wondering if thats not a good idea
I used to have my external BOV connected to the top of the "T" and that would only go off when i hit about 5 - 7 psi. so i wouldn't use it as a W/I source if i was you.
 

·
Registered
Joined
·
3,195 Posts
went out today and did some much needed rerouting of vac lines. prettied everything up and used a normal t for the waterinjection, it is working MUCH better now. see, i knew this forum was good something...;)
 

·
Registered
Joined
·
506 Posts
noTe said:
Yes guys, It is the brake booster line. Just zip tie it, I zip tied mine a year ago.
I do believe that that line in the picture goes to the EVAP system for the gas tank. There is a much bigger line going to the brake booster.
 

·
Registered
Joined
·
1,120 Posts
dude just zip tie like the other guy mentioned earlier... if it's not meant to be there it wouldn't have been put there in the first place. and if the valve goes bad then replace it!
 
1 - 20 of 22 Posts
Top