Dodge SRT Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
1,181 Posts
Discussion Starter · #1 ·
p0440- general evap system failure
p0456- evap system small leak

The car runs perfectly fine and when i reset the computer the code doesnt show for a couple days ...where should i look for a leak or problem?
 

·
Premium Member
Joined
·
14,830 Posts
nasty, how many times has this happened? Most common for those would be the gas cap, if it's not sealed, the vac the system pulls leaks and sets the codes. Second would be the evap stuff by the steering rack, under the trans, followed by the NVLD assembly by the passenger rear tire, look in my gallery for a pic titled "NVLD"

check for loose vac lines
 

·
Premium Member
Joined
·
14,830 Posts
doh, take a good look at your gas cap itself, the gasket might have a tear in it.
 

·
Premium Member
Joined
·
14,830 Posts
P0440-GENERAL EVAP SYSTEM FAILURE
When Monitored: Engine Running. Fuel Level greater than 12%. Ambient Temperature
between 4°C and 32°C (39°F and 89°F)

Set Condition: The PCM does not see the NVLD switch close during the medium/large
leak test. The PCM will then increase the vacuum supply to the EVAP system by
increasing flow through the EVAP Purge valve. If the switch does not close with an increase in vacuum, an error is detected. Two Trip Fault.

P0456-EVAP SYSTEM SMALL LEAK
When Monitored: Ignition off. Fuel Level less than 88%. Ambient Temperature between
4°C to 43°C (39°F to 109°F)

Set Condition: Due to temperature changes a vacuum is created in the fuel tank and
EVAP system. With the EVAP system sealed, the PCM monitors the NVLD switch. If the
NVLD switch does not close within a calibrated amount of time an error is detected.

The procedures call for using the DRBIII after a thorough visual inspection of ALL hose and such in the vac sysytem, followed by using a smoke generator to check for leaks you can't see. Myself, I would get a Mityvac tool and sart pulling vac acroos different parts of the system.
 

·
Registered
Joined
·
1 Posts
p 1494 code

Have an 01 Dakota 4.7 that is getting the leak detection pump code. Can anybody tell me where this thing is? It says to check the hoses, but I can't seem to find them. The diagram on under the hood shows it somewhere near the driver's side front ???? I am a noob and need help. Thanks.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top