Dodge SRT Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
2,283 Posts
Discussion Starter · #1 ·
I just installed the s2 wg, took me a nice 4 hours to do it right. :flame: But now im seeing spikes at 18-19 and holding 14-15 to the redline WITHOUT a MBC. Is that normal? What else should i expect? The ecu will learn and turn down the boost? I didnt change anything on the vacuum lines.
 

·
Registered
Joined
·
1,748 Posts
Fluke-SRT4 said:
I just installed the s2 wg, took me a nice 4 hours to do it right. :flame: But now im seeing spikes at 18-19 and holding 14-15 to the redline WITHOUT a MBC. Is that normal? What else should i expect? The ecu will learn and turn down the boost? I didnt change anything on the vacuum lines.

I am seeing the exact same thing on my 2004, the PCM will get wise, atleast mine does and I have to reset it, then I'm boosting high again...
 

·
Registered
Joined
·
2,283 Posts
Discussion Starter · #9 ·
Lucille said:
me either, my 2004 is bone stock except for the stage 2 wastegate....

it got me from a 14.3 to a 14.1 and a couple of mph..........


Hey Mine is not stock, it has the stage 1 installed, I told that!!!! Im not liking the ideia of messing around with thevacuum lines, i tried and then boom, i was boosting only 5 psi. put back the stock way came back to 19psi, and this was before the s2 wg with a BC.

And i see people putting the green or the blue line on the BOV, what help that can give me?
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top