Dodge SRT Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,547 Posts
Discussion Starter #1
My clutch slave cylinder failed on my SRT-4 has anyone else had the same problem? I posted a picture on the srt trouble section of this forum. The failure happened at 1080 miles. I still love the car.
 

·
Registered
Joined
·
243 Posts
Haven't heard of that happening before. Time for a trip to the dealership.

Mu clutch slipped the other day while racing an LS1 powered Z28. It's fine now, though. Just have to take it easy frrm now on.
 

·
Premium Member
Joined
·
1,294 Posts
If you can find out what failed when they fix/replace it let us know. It may have been something as simple as a seal put on backwards during manufacturing.

I have heard of several other manufacturing failures (including my map sensor), but nothing as far as a consistent failure on any one component.
 

·
Registered
Joined
·
1,504 Posts
hey srt4 , would that happen to be you kf6pbe???
 

·
Registered
Joined
·
1,547 Posts
Discussion Starter #7
Yes it is me in the TEXT. Thanks I have found the forum and it is nice too.
I hope that it is something extermley rare in my case with the clutch slave and I will post any info about my problem. I found my thermostat housing bleed fitting for releasing trapped air after reading about the head gasket. Good info here.
 

·
Registered
Joined
·
1,504 Posts
i looked around again.. i think the kid said his clucth was slipping.. so i guess i was wrong :?
 
1 - 8 of 8 Posts
About this Discussion
7 Replies
5 Participants
thispainisours
Dodge SRT Forum
The community to discuss high-performance Dodge vehicles from the SRT and PVO groups, SRT-4, SRT-6, SRT-8, and SRT-10. Come join the fun!
Full Forum Listing
Top