Dodge SRT Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Ok guys I need help from the OGs here I get white smoke after I go wot or high rpm it smokes for about 5 mins after I do it won't smoke with normal shift, I've run a compression test and it's 155,154,153,153 I've replaced the PCV and the PCV hose(in thoughts it might be clogged) I also just recently rebuilt the turbo. I'm running into dead ends here guys and I really need your help
 

·
Premium Member
Joined
·
4,153 Posts
do a leakdown test. Couple be a valve seal which typically leak with high vacuum.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Did valve seals about 100 miles ago, also leakdown came back at 3-4 % on each cylinder with comp at 155 across the board
 

·
Registered
Joined
·
3,107 Posts
It could be oil left in the exhaust system, and it's burning off when you heat it up enough at WOT. How long since the turbo rebuild. When I had smoking at about 190K miles, it was the BWS turbo I was using.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
The previous engine did melt a piston and was throwing tons of oil in the exhaust, and everywhere for that fact. I thought I cleaned most of it out, but it's weird it only smokes after wot or high rpm, heard some people tell me it's my oil control rings, but it leakdown and comp tested perfect
 

·
Registered
Joined
·
42 Posts
My turbo seals went out on me and my car was smoking so bad I thought the car was on fire. See if the smoke is coming from your turbo it’s common for turbos seals to Go out and cause smoke from burning oil. Is your smoke coolant Or oil was your turbo rebuild legit or maybe the seals could still be the problem
 
1 - 6 of 6 Posts
Top