Dodge SRT Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
1,556 Posts
Discussion Starter · #1 ·
I figured out from talking to Kevin at AGP that my E-01 is not properly setup to run an external wastegate and because of this, my 18-25psi wastegate spring is opening at 12psi.

Currently in the engine bay I have the lower pressure nipple on the wastegate going to the e-01's boost solenoid and the higher pressure nipple on the wastegate uncapped and venting to atmosphere.

Sounds like there is something that needs to be on the wastegate nipple on the top. Can anyone tell me how their wastegate is setup with the e-01?

Also, are there any internal adjustments that I need to make on the e-01 itself?

Thanks a million!
 

·
Registered
Joined
·
502 Posts
Thats how I have mine set up too, except Im using the nipple on the compressor instead of the manilfold like you said.

Just make sure you have the fittings in the right spots on the Greddy solenoid and that the "NO port" is un-capped and left open.
 

·
Registered
Joined
·
1,556 Posts
Discussion Starter · #6 · (Edited)
I just went out to the car and checked my setup. All I changed when I installed the turbo was take the vaccuum hose off the stock wastegate and put it on the external wastegate's lower hose.

Here is how I have mine hooked up (I'm concerned with how I have the hoses routed into the boost solenoid. It's been like this since I hooked it up on the car with the stock turbo. Per Hector's instructions.) Looks completely different then what you have. I'm kind of worried now...

Ps, dont be jealous of my mad tite ms paint skillz! :lol:

 

·
Registered
Joined
·
502 Posts
silverscooby said:
I just went out to the car and checked my setup. All I changed when I installed the turbo was take the vaccuum hose off the stock wastegate and put it on the external wastegate's lower hose.

Here is how I have mine hooked up (I'm concerned with how I have the hoses routed into the boost solenoid. It's been like this since I hooked it up on the car with the stock turbo. Per Hector's instructions.) Looks completely different then what you have. I'm kind of worried now...

Ps, dont be jealous of my mad tite ms paint skillz! :lol:
You need to change that!
The stock wga uses different ports compared to the external wastegate.
You need to hook it up like the pic Nivo posted.

Or, you can hook it up like mine...

The "NO" port gets no use, un-used, left open.
The "COM" port goes directly to the top nipple of the external wastegate.
The "NC" port goes to a "T" which will hook to the bottom nipple of the wastegate and the compressor housing nipple. This setup uses NO stock lines and is all to itself, unless you hook it to the manifold like Nivo instead of the compessor nipple.
 

·
Registered
Joined
·
1,556 Posts
Discussion Starter · #8 · (Edited)
Fixed the picture, should work now. Yeah, I didnt know that the boost solenoid had to be switched when going from internal to external wastegates.

I will change it tonight when I get home but I have one question....

If I switch it to be like Nivo's, what do I do with the black stock looking vaccuum line (in my diagram) and the nipple coming off the turbo? Do I connect those two?
 

·
Registered
Joined
·
502 Posts
silverscooby said:
Fixed the picture, should work now. Yeah, I didnt know that the boost solenoid had to be switched when going from internal to external wastegates.

I will change it tonight when I get home but I have one question....

If I switch it to be like Nivo's, what do I do with the black stock looking vaccuum line (in my diagram) and the nipple coming off the turbo? Do I connect those two?
I updated my post right before this one.

If you hook it up like Nivo's, the the compressor nipple gets unused, capped off.
That stock black line your talking about that comes from the brake booster area goes to the manifold, along with the "NC" port and the bottom wastegate nipple if you hook it up like Nivo. You'll also have your BOV hooked there and the greddy pressure sensor which will make all these conectons to one manifold nipple hard to do.

Thats why I did it the way I described in my previous post, its nice and simple that way.
The only thing I have coming off my manifold is the stock black line, greddy pressure sensor and my BOV.

The greddy solenoid, wastegate and compressor nipple are totally on their own.

Good luck! :rofl:
 

·
Premium Member
Joined
·
9,774 Posts
our original spring was 9.4 psi and the max we saw was 10psi out of it, we bought a new spring from ATP and now see 13psi with ebc off. when we turn it up we see what ever we push the turbo to. so far it has been 23psi to redline and holds there.
 

·
Registered
Joined
·
502 Posts
silverscooby said:
Ok, I have everything hooked up like you Eric.....

But....

It's still only holding 12psi until the wastegate opens.

When you shut off your boost controller, what are you able to hold?
I think mine only holds 13 to 14psi also, but with the e-01 turned on it will hold what ever I want it to, so far Im boosting 22psi all the way to redline just fine!
 

·
Registered
Joined
·
1,556 Posts
Discussion Starter · #15 ·
I really appreciate your help guys. I'm here in the boonies so there arent too many guys who know turbo cars. Most people around here think that if it doesnt have at least 302 cubes, than it's worthless. :)

Btw, do you guys have your wastegate dump tubes venting to atmosphere? I swear to god, I made a guy on the side of the road drop his groceries when I went by him as I hit 12psi.
 

·
Registered
Joined
·
502 Posts
silverscooby said:
I really appreciate your help guys. I'm here in the boonies so there arent too many guys who know turbo cars. Most people around here think that if it doesnt have at least 302 cubes, than it's worthless. :)

Btw, do you guys have your wastegate dump tubes venting to atmosphere? I swear to god, I made a guy on the side of the road drop his groceries when I went by him as I hit 12psi.
Yes mine is dumped too!
Its great isnt it?! :rofl:
Once you get your e-o1 all set up and the boost controller part set, its nice to drive. I can drive somewhat aggressive and keep it just under the point of my dump opening and still have it quite, but when I floor it and hit my preset boost, look out for the sonic boom when that dump opens!! :thumbsup:
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top