Dodge SRT Forum banner
21 - 40 of 42 Posts

·
Registered
Joined
·
635 Posts
car is back in the dealer yesterday. I got a call, they said they have to re-do both connectors on the back window. Car will be with them until next week. I'm not picking the car up and dropping it off everytime. This is frustrating!!!:flame:
 

·
Registered
Joined
·
3,253 Posts
Wow.. Mine works fine :D. I dont even use it.. I live in Arizona. Hopefully I'll use it one day. (Knocks on wood)
 

·
Registered
Joined
·
3,253 Posts
rudedog said:
If you dont use it....how dya know it works:rofl: ???? Mine had the orange light that comes on but it didnt work. Anyway good luck to ya when you plan on using it hehehe
Not quite sure haha, My orange light does turn on though.
 

·
Registered
Joined
·
1,019 Posts
My rear lamps and defroster stop working and it was the red 10 (#7) inside.
 

·
Registered
Joined
·
635 Posts
Got a call from the dealer and now the entire back window will be replaced. They are getting power to the rear but not through the window grid. All this trouble for a rear defroster!!!! I think they should assign a parking spot for my car at the dealer:eveilgrin
 

·
Registered
Joined
·
8,988 Posts
Silver SRT4 said:
rudedog said:
If you dont use it....how dya know it works:rofl: ???? Mine had the orange light that comes on but it didnt work. Anyway good luck to ya when you plan on using it hehehe
Not quite sure haha, My orange light does turn on though.
You must not get up early enough. I've had to use mine alot this past couple of weeks.
 

·
Registered
Joined
·
635 Posts
Actually, I get up at 4 am and leave at 5 am. Thats why its nice to have 3 other cars with working rear defroster as back up. (Except for the cougar..No rear defroster) Dealer told me I'll get my car back on Friday. Just enough time to get it clean for the Big Dogs Grill meet on Saturday!
 

·
Registered
Joined
·
635 Posts
I gotta say f...in dealers:flame: . Got my car back last Friday and still not fixed. They said glass did'nt come in and will be here monday. Dropped it off sunday night and no glass on Monday. Tuesday comes still not here. It came in today and they will install it. Said it should be ready today. WE"LL SEE ABOUT THAT!!!!
 

·
Registered
Joined
·
635 Posts
Finally working

Rear defroster finally working. A quick recap. Wiring from engine compartment to switch replaced, the switch itself has been replaced, wiring from the switch to the glass replaced and finally the rear glass replaced. However during the reassembly the pillar post does not stay on. It pops off when I hit a bump. I guess its going back for a new one. They should anyways. They've put dirty fingerprints all over it. Lets see how long this lasts.:rofl:
 

·
Registered
Joined
·
635 Posts
Not Working Again

Well the rear defroster not working again. I don't think that's where the problem is. I can't find the thread!!!!! Someone was mentioning about some wires underneath the shifter boot. I think its the reverse light switch that pops the fuse. Can anyone confirm this???:confused:
 

·
Registered
Joined
·
635 Posts
I was thinking about installing NOS. Thank you for giving me that idea. If the efffing dealer cant fix it. Then NOS button it is baby!:eveilgrin I guess ice on the rear windshield is only for couple more weeks anyway.
 

·
Registered
Joined
·
635 Posts
Yeah...the car is going back to the dealer tuesday...to get the defroster looked at again. Since I dont have too many mods and I dont race people all the time. NOS is the best bang for the buck. I'm only going to do 75shot. I'm not too ambitious and using 100-150shot like some people. That should be plenty:eveilgrin Originaly, I wanted the button on the shifter. I'm still on the pricing stage.
 

·
Registered
Joined
·
165 Posts
My car has been popping that #7 fuse for a couple months now, I took it to the dealer and they replaced the fuse so it could pop again, thanks alot. I know it has something to do with the reverse lights because as soon as I put it in reverse the fuse pops but I havn't had the time to look at it.
 

·
Registered
Joined
·
1,019 Posts
Mine is the defroster switch, but the same fuse. Its getting warm now, so I just don't worry about it and I'm just careful when backing up. I'll fix it eventually.
 
21 - 40 of 42 Posts
Top