Dodge SRT Forum banner
1 - 20 of 42 Posts

·
Registered
Joined
·
319 Posts
Discussion Starter · #1 ·
Anyone know what might have caused this. I checked the fuse and it is fine. Could it have gotten disconnected, what is the easiest way to get to the connector? Do I just need to remove the rear deck area to get to it? Thanks and sorry for the newb style question.
 

·
Registered
Joined
·
486 Posts
Do your reverse lights still work?
 

·
Registered
Joined
·
319 Posts
Discussion Starter · #5 ·
Any advice? It's getting to the time of year where I need the rear defroster pretty much daily. And it's pretty annoying wiping the rear window off with a towel.
 

·
Registered
Joined
·
947 Posts
AngryNeon said:
Any advice? It's getting to the time of year where I need the rear defroster pretty much daily. And it's pretty annoying wiping the rear window off with a towel.
Make sure it's the right fuse, It's suppose to be # 7
I have the same problem right now.
 

·
Registered
Joined
·
947 Posts
SRT$ said:
mine didnt work when i bought it. bring it back and they will fix it for free. it was disconnected in the back
Danm I wish mine was disconnected also, but I replace the fuse and it works for a while and then it goes out again and again and again.
Bad thing where I live it snows so I needed bad.:jester:
 

·
Registered
Joined
·
635 Posts
I don't like the sound of this......My cars defroster has never worked. I didn't care at first. Since the warranty is about to expire I decided to get it fixed. Took it to the dealer and they said the fuse blew. They replaced it. Next day I brought it back (it blew again). They told me the cig lighter jack wiring was bad. Asked me what have I been plugging in it? I told them they were high. Gave the car to them when parts came in. They called me said car was done. I came late at night turned the car on. Turned on the defroster and it didnt work. Drove it 40ft to the early bird drop off and left. This time they said the defroster switch was bad. Ordered the part again. They told me it was ready. I picked up me car and everything was fine. The next 2 days I turned on the defroster off and on as many times as I can. I was glad it was fixed. I went to work on a cold morning turned it on, the lights turned on but the defroster was NOT working:flame: :flame: The dealer called and they are replacing all the wiring to the rear of the car. I brought the car back again:stab: As it sits now. The car is at the dealer. I'll see what they say tomorrow.:flamingde :knockhead :malee: If it wasnt under warranty I probably would give up!
 

·
Registered
Joined
·
635 Posts
I got my car back yesterday and I can't turn on the defroster yet. Some type of glue has to cure for 24 hrs. I'm getting really annoyed with the dealer going back and forth. At least I got a free alignment out of it. I'll find out tomorrow morning if the defroster works. However my sunroof went Kapoot this morning:crying: its stuck sheesh....... Lets see what the next episode brings.
 

·
Registered
Joined
·
635 Posts
Ok my defroster is out again:knockhead :flamingde :flamingde I'm just so glad I have 3 other cars I can use while its in the shop. Looks like the car is going to be taking up residency at the dealer. This time it looks like the glue at the rear window that holds the little connector has come unglued. Aaaaagggghhhhhhh!!!!!!!!!!!!!!!!! F......in dealers!!!!!
 

·
Premium Member
Joined
·
5,120 Posts
No- think you asked me that before. I even replaced the bulbs. Well I replaced ONE of them, the other one I dropped INSIDE the taillight and its just rolls around when I drive. What does that mean?
 

·
Registered
Joined
·
635 Posts
if you have no reverse lights or rear defroster that usually means its your fuse. Fuse #7 in the engine compartment. If that fuse keeps on blowing. The usual fixes are wiring by the shifter is pinching. I heard a couple of people on here got this fixed fairly quickly. But if your orange light turns on but does not defrost. Check the connection on the rear window. Passenger side. Might be able to see the connector without removing the pillar. I had to, but it wasn't hard. It pops rights off. The connector on mine came completely off:crying: . The dealer reglued it but came off again:flame: . It goes back to the dealer tomorrow. I'll keep ya'll posted. Who knows they might replace the entire back window.
 
1 - 20 of 42 Posts
Top