Dodge SRT Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter · #1 ·
The Setup:
Mopar Stage 1 - AGP WGA - TurboXS HPMBC
15-16psi spike/holding 14-15psi till redline.

First and second seem to be fine but once I hit third, it falls flat on it's face. It spools extremely slow (as in 1psi a second from 8psi to 15psi if I'm lucky).
This is on 94 octane. I hit the track and had these problems so I threw moey at it :lol: and added a half tank of 110...$2.62CDN...a LITRE ($8/gallon), that didn't help anything. Air temp that night would have been around 70 with about 80% humidity.

At this point I'm a little disapointed in Stage 1, I had fewer problems with Stage 0. I upgraded to Stage 1 for saftey/modding's sake but I'm about ready to give up and put everything back to stock (with Stage 1 installed).

Suggestions?
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #4 ·
It seems to be fine in first and second though. It spools instantly in one - instantly two - 3rd, stops boosting. And it starts "chugging" around 4-5000RPM
 

·
Registered
Joined
·
4,241 Posts
Garlond said:
The Setup:
Mopar Stage 1 - AGP WGA - TurboXS HPMBC
15-16psi spike/holding 14-15psi till redline.

First and second seem to be fine but once I hit third, it falls flat on it's face. It spools extremely slow (as in 1psi a second from 8psi to 15psi if I'm lucky).
This is on 94 octane. I hit the track and had these problems so I threw moey at it :lol: and added a half tank of 110...$2.62CDN...a LITRE ($8/gallon), that didn't help anything. Air temp that night would have been around 70 with about 80% humidity.

At this point I'm a little disapointed in Stage 1, I had fewer problems with Stage 0. I upgraded to Stage 1 for saftey/modding's sake but I'm about ready to give up and put everything back to stock (with Stage 1 installed).

Suggestions?
Garlond, how do you have the vacuum lines set up and have you checked for leaks? Something is not right as others with the same mods are doing fine!

Let me know
Mike Candler
 

·
Registered
Joined
·
3,109 Posts
it is not related to ignition timing, it is in the setup of your boost controller and related lines.
 

·
Registered
Joined
·
959 Posts
A stage 1 car with a Stage 2 WGA pulled timing on a local dyno when he tried to tighten the WGA...

I had questions last week about timing being pulled, and predictably, since the topic didn't relate to "what is the loudest BOV, WHat is the best exhaust, What is a MAP CLAMP, Define Stage 1,2,3," the responses were slim to none..

Try resetting your computer..
 

·
Registered
Joined
·
5,204 Posts
You either hooked it up wrong. Or tuned it poorly.
 
1 - 9 of 9 Posts
Top