Dodge SRT Forum banner

1 - 20 of 30 Posts

·
Registered
Joined
·
1,926 Posts
Discussion Starter · #1 ·
Okay, I have checked the lines, they are correct. I set everything to zero. I had a friend who has tuned the profec help me, and well we were getting 30psi+ spikes, the throttle peddle would stiffen up and the bov would blow off in the middle of throttle, and it did this w/everything @ zero. I don't know whats going on. I'm thinking about taking it off and just selling it I'm so frustrated and disappointed with it.

Any help is GREATLY appreciated.
 

·
Banned
Joined
·
184 Posts
i know how you feel and without pictures i can't really help you. when i installed my unit it wasn't working(no boost). i went through and rewired everything 10 times and it still wasn't working. so i gave up and left and as i was driving home i let it rip and boom 19psi. you probably have a leak somewhere but without pics its useless for me to just guess. if i had a choice i'd go with a better ebc.
 

·
Registered
Joined
·
1,926 Posts
Discussion Starter · #3 ·
Well I can't afford the e01 and a majority of people i have seen are using the Profec B SII...what exactly do you need pictures of?
 

·
Registered
Joined
·
322 Posts
Ok, from memory. I have the profec B Spec II with stage 2. My settings:

Boost %53
Gain 0
start boost 110

With stage 0 I think I had boost % a little lower and the gain was at 100
 

·
Banned
Joined
·
184 Posts
alpine said:
Well I can't afford the e01 and a majority of people i have seen are using the Profec B SII...what exactly do you need pictures of?
of the install dude.. so maybe someone(not specifically me)can spot what you did wrong.
 

·
Registered
Joined
·
1,926 Posts
Discussion Starter · #6 ·
chris6543 said:
Ok, from memory. I have the profec B Spec II with stage 2. My settings:

Boost %53
Gain 0
start boost 110

With stage 0 I think I had boost % a little lower and the gain was at 100

Okay, I'd love to try something like that, but my car spikes @ 30psi or higher, no matter the setting, warning boost level and boost level drop I have set, it hits 30psi+ Also, when rolling on the throttle, I can feel the peddle pushing back against my foot, if I fight it, you can hear a sort of flutter from the turbo and the boost keeps rising until it hits 30 or so psi...I will try to get pics up, I won't have a camera anywhere near me for a few day though.
 

·
Registered
Joined
·
1,086 Posts
Hey Alpine,
I got this from Dougnosser a while back. It helped me alot! Maybe it'll help you as well. And here's the threads when I was installing mine.

http://www.srtforums.com/forums/showthread.php?t=37352

http://www.srtforums.com/forums/showthread.php?p=529693#post529693


Ok, it doesn't matter what I have mine set at becasue my base settings are different. Here is how to set yours up.

SET- this allows you to set the boost. It will display as a %. It is actually a % of your base setting. If you are holding 11psi at redline now, the equation goes something like this. 11(psi)+20%= 13.2psi approx.

GAIN- is to hold boost. If you notice it's dropping off at redline, you can turn this % up so the boost won't fall off as much. Keep in mind turning this up will also increase the initial spike in boost the car will see.

SET GAIN- this is a digital control of the wga. Setting it at 130 means you are telling it not to start opening until 13psi. It will start to bleed off boost at 13psi and have the wg door fully open at whatever boost you want. This will also help spoolup by bleeding off boost a little.

WARNING- is at what boost do you want the screen to start flashing , indicating that you are going above what you have the limiter set for. IE: you set it for 210(21psi) and anything over 21 psi of boost it will start to flash and reduce boost according to your settings(see below)

WARNING LIMITER- this is what you want the boost to be reduced by. If you have you "SET" % at 38%, and your warning limiter % at 10%, you are basically asking the boost controller to reduce you SET feature to go to 28% (38%-10%=28%)

I hope this helps. Start by setting your "start gain" at about 120(12psi). Then adjust your gain to about 20%. The SET should be at 0%. Work in increments of 2% and start to turn up the boost until you happy. If you set the "SET" first and adjust the gain later, you'll get more spiking than you want the boost controller to have and have a more difficult time trying to adjust it. In my honest opinion I wouldn't hold more than 15-16psi max at redline. Ok, here are my settings, they will vary from yours as I have different base WGA settings.

SET: 39%
GAIN: 26%
START GAIN: 120
LIMITER: 220
WARNING LIMITER: 9%

Good luck man! I know what a PITA it is trying to fine tune this thing, :flame: but be patient! You'll eventually get working just right, and when you do, you'll love it!! :thumbsup:
 

·
Registered
Joined
·
1,926 Posts
Discussion Starter · #8 ·
GiJoe said:
Hey Alpine,
I got this from Dougnosser a while back. It helped me alot! Maybe it'll help you as well. And here's the threads when I was installing mine.

http://www.srtforums.com/forums/showthread.php?t=37352

http://www.srtforums.com/forums/showthread.php?p=529693#post529693


Ok, it doesn't matter what I have mine set at becasue my base settings are different. Here is how to set yours up.

SET- this allows you to set the boost. It will display as a %. It is actually a % of your base setting. If you are holding 11psi at redline now, the equation goes something like this. 11(psi)+20%= 13.2psi approx.

GAIN- is to hold boost. If you notice it's dropping off at redline, you can turn this % up so the boost won't fall off as much. Keep in mind turning this up will also increase the initial spike in boost the car will see.

SET GAIN- this is a digital control of the wga. Setting it at 130 means you are telling it not to start opening until 13psi. It will start to bleed off boost at 13psi and have the wg door fully open at whatever boost you want. This will also help spoolup by bleeding off boost a little.

WARNING- is at what boost do you want the screen to start flashing , indicating that you are going above what you have the limiter set for. IE: you set it for 210(21psi) and anything over 21 psi of boost it will start to flash and reduce boost according to your settings(see below)

WARNING LIMITER- this is what you want the boost to be reduced by. If you have you "SET" % at 38%, and your warning limiter % at 10%, you are basically asking the boost controller to reduce you SET feature to go to 28% (38%-10%=28%)

I hope this helps. Start by setting your "start gain" at about 120(12psi). Then adjust your gain to about 20%. The SET should be at 0%. Work in increments of 2% and start to turn up the boost until you happy. If you set the "SET" first and adjust the gain later, you'll get more spiking than you want the boost controller to have and have a more difficult time trying to adjust it. In my honest opinion I wouldn't hold more than 15-16psi max at redline. Ok, here are my settings, they will vary from yours as I have different base WGA settings.

SET: 39%
GAIN: 26%
START GAIN: 120
LIMITER: 220
WARNING LIMITER: 9%

Good luck man! I know what a PITA it is trying to fine tune this thing, :flame: but be patient! You'll eventually get working just right, and when you do, you'll love it!! :thumbsup:

Thanks.

Also, if I turn the ebc off, shouldn't it run how it was when I just had S2 in, no ebc? And if it doesn't then there must be something wrong w/the lines, correct? But I have quadruple checked (maybe more) the lines, and they are fine. I just don't know anymore :lol: So frustrating.
 

·
Registered
Joined
·
1,926 Posts
Discussion Starter · #10 · (Edited)
Okay, I dunno wtf I did, I just rechecked all connections, ziptied those mofo's down tight and no more insanely high spikes - really not much at all, only spiked what I set the start boost to, then bled to 15 or so...dunno how to fix that. The throttle problem went away for the most part, felt it a little on the way home tonight.

Oh yea, and w/the ebc off, I was told it was supposed to be hitting what the wga is set too, so for me 20psi spike 18psi to redline, well, it hold a steady 4.5psi throughout...wtf is up with that. :flame:

edit:

I have the set boost @ 50%, gain @ 14%, set gain @ 85 and I am getting 20psi spike, then it bleeds all the way down to 14psi....any way to get it to hold 20psi? I was holding 18psi before i put this on (s2 w/o toys installed)
 

·
Registered
Joined
·
1,086 Posts
alpine said:
Okay, I dunno wtf I did, I just rechecked all connections, ziptied those mofo's down tight and no more insanely high spikes - really not much at all, only spiked what I set the start boost to, then bled to 15 or so...dunno how to fix that. The throttle problem went away for the most part, felt it a little on the way home tonight.

Oh yea, and w/the ebc off, I was told it was supposed to be hitting what the wga is set too, so for me 20psi spike 18psi to redline, well, it hold a steady 4.5psi throughout...wtf is up with that. :flame:

edit:

I have the set boost @ 50%, gain @ 14%, set gain @ 85 and I am getting 20psi spike, then it bleeds all the way down to 14psi....any way to get it to hold 20psi? I was holding 18psi before i put this on (s2 w/o toys installed)
Sorry guy. I guess you're outta my league now. I'm not a S2 baller yet so I don't know what the stats are on that thing. I do know that everyone I've talked to sais that it's normal for your boost to drop like that. I think 14 is kinda low though. I boost at 19.5 and by red line it drops to about 16.5. This may sound strange but when your boosting are you reading the ebc or your stock boost guage. The ebc is the best source for reading boost level. I know that my stock boost guage sticks sometimes. If you tap the side of it while your boosting see if the needle moves.
 

·
Registered
Joined
·
1,926 Posts
Discussion Starter · #13 · (Edited)
I am reading the stock one, I'm going to go out and try to watch the ebc, kinda hard though b/c its on the steering column and its hard for me to take my eyes off of the road.

Edit:

ebc is reading 197 (19.7psi) spike then it bled all the way down to 127 (12.7psi) right about 6300rpm or so.
 

·
Banned
Joined
·
184 Posts
alpine said:
I am reading the stock one, I'm going to go out and try to watch the ebc, kinda hard though b/c its on the steering column and its hard for me to take my eyes off of the road.

Edit:

ebc is reading 197 (19.7psi) spike then it bled all the way down to 127 (12.7psi) right about 6300rpm or so.
um the fuel cut off point is before 6300 but regardless of that you shouldn't past 6100.. the redline is there for a reason. i'd do it at the track maybe but its a little dangerous and not only that when you get into higher rpms you start running rich if you don't have some type of ems. so the point is moot =/
 

·
Registered
Joined
·
1,926 Posts
Discussion Starter · #16 · (Edited)
Okay, well, I have to take it off to take my car to the dealership, [Editted to make it DCx safe]...dunno how, but I just don't want them giving me shit for having the ebc in...besides, it's the most inconsistant pos evAr. I don't think I'll be putting it back in my car after I get it back from the dealer.
 

·
Registered
Joined
·
3,464 Posts
Hmm, weird. Mine's been rock solid for months now.
 

·
Registered
Joined
·
1,926 Posts
Discussion Starter · #18 ·
Yea, I dunno, maybe I got the POS one of the bunch...One minute it's goin smoothly - 20psi spike bleeding to 15 (not what I want, but its not bouncing the damn needle) then the next time...bam, bounces the boost guage needle and the thing fuckin beeps at me like i hit the warning, which is set @ 21psi and I barely hit 17psi...wtf. I dunno, I want to just go back to spiking 20 and holding 18 to redline...felt soo nice :)
 

·
Registered
Joined
·
3,464 Posts
I have my warning feature set to like 30 PSI. Who need a warning feature anyway. The boost gauge is your warning feature.

Also, the needle will fluctuate around if your GAIN is set too high. Mine's only 12%. My SET boost is 43% for 18.5 PSI, and my SET GAIN is around 130, which is what my WGA is set at. I get instant spike to 18.5 PSI, and it holds there until 5000 rpms where it starts to slowly drop down to 15.5.

How do you have yours set-up? Mine's off the Manifold source.
 

·
Registered
Joined
·
1,926 Posts
Discussion Starter · #20 ·
Mine was doin' fine around 14%, now its all the way @ 4% because the needle was bouncing... I have my set gain at like 95...maybe I should play w/that a little.

T'd off the TB is how I have mine.
 
1 - 20 of 30 Posts
Top