Dodge SRT Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
170 Posts
Discussion Starter · #1 ·
title pretty much says it guys. i have a turboXS MBC, stock WGA, turboXS RFL BOV w/agp blockoff plate, and mopar exhaust. i have removed ALL of the stock vacuum lines from the solenoids on the airbox. i have the WGA hooked to the MBC, and back to the turbo. i have the nipple on the turbo where the stock surge valve was, capped off, and block off plate installed. i have the turboXS BOV routed to a T where the vacuum lines connect by the throttle body. plugged the red line to eliminate overboost codes. all of the other colored vacuum lines going to the stock solenoids have been removed. i cannot find any vacuum leaks. i thought i had a boost leak on the cold side of the intercooler piping, so i tightened all the clamps, and it still wont hold more then 9psi by redline. my MBC will allow me to hit 17psi, then slowly start falling to eventually 9 by redline. is this just because im still using the stock WGA, or do u guys think i have a boostleak somewhere? i am getting the AGP WGA soon so hopefully that will help, but i think 9psi at redline seems kinda low even for the stock WGA. or am i totally wrong, and my car is probably fine? i made sure all of the lines i removed, were capped where needed as well.
 

·
Registered
Joined
·
642 Posts
no that sounds about right...with the stock WGA and the PCM not controlling boost anymore, your boost at redline is being held by the stock 4lb WGA spring. once you upgrade the WGA you should be holding like 14-15psi.
 

·
Registered
Joined
·
3,200 Posts
JustANeonButBadass said:
no that sounds about right...with the stock WGA and the PCM not controlling boost anymore, your boost at redline is being held by the stock 4lb WGA spring. once you upgrade the WGA you should be holding like 14-15psi.
not true i have stock waste gate and i spike 19 fall back to 15 and the to 13 to redline.. hes not got it adjusted right. did you adjust the corse screw or the fine adjust.. also you should be pulling all vacum lines from manifold.. if you need help e mail me..

p.s take all lines off you dont need them.. hit me up i will help you.
 

·
Registered
Joined
·
7,044 Posts
i would say seems about right. i'm sure it's not exactly 9 all the time. if your like the rest of us it easily changes with many variable. i'd would of left it all alone until i had everything i needed. just seems like a bid headache to me. but good luck try to get it working. but i still think after the wga install all will be good.
 

·
Registered
Joined
·
1,894 Posts
JustANeonButBadass said:
no that sounds about right...with the stock WGA and the PCM not controlling boost anymore, your boost at redline is being held by the stock 4lb WGA spring. once you upgrade the WGA you should be holding like 14-15psi.

He's right. The green line that came from the turbo to the solenoid is where the stock WGA get's it's vac source from.....then the solenoid controls it and send it back through the black line to the WGA. The computer limits how much boost the WGA sees so it can hold the typical 13 @ redline. Keep in mind your stock WGA has a 4lb spring so if u were to just hook the WGA up without using the computer it would see ONLY 4 psi. That's how you have it setup except you have an MBC in there and that's why you are gettin the spike and only holding 9 to redline. Id either get an aftermarket WGA or hook the vac lines back up to the solenoid and use the MBC to get a little more boost.....but if you do that the computer will most likley adjust to bring it back down to stock levels. If that doesnt make sense im sorry.
 

·
Registered
Joined
·
170 Posts
Discussion Starter · #7 ·
makes perfect sense. thank you guys for ur input. ill be installing the AGP WGA as soon as i get the money to order it in a week or so. so hopefully ill be ok then. i kinda figured that was all i needed, but i just wanted to make sure everything seemed ok with the current setup until i get it. i will make sure to post back after i install it to let everyone know if that was the only issue.
 

·
Registered
Joined
·
170 Posts
Discussion Starter · #8 ·
just wanted to post my results. i currently setup the spring mod while im waiting to get my WGA. and sure enough now it spikes to 20psi, falls and holds about 17psi, and then falls to 15psi at redline. so it was just the stock WGA all along. thanks for the help guys. car seems to wake up ALOT more on the throttle now lol.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top