Dodge SRT Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
whenever i floor my car at low rpm's it kinda bogs out and shoots out these little backfires really fast and doesnt sound good at all. i was thhinking maybe the engine was getting to much fuel? my mods are agp wastgate, perrin bc, aem cold air, bdj exhuast, ngk plugs, s1.

thanks
 

·
Premium Member
Joined
·
14,830 Posts
Don't floor your car at low RPMS, that's incorrect drivng technique.

There, fixed:)
 

·
Registered
Joined
·
11,093 Posts
That sounds odd. I see your mods, but have you messed with any of them. have you done any mods and then undo them?

Give me more info suka. I need more info!

:)
 

·
Registered
Joined
·
11,093 Posts
glhs837 said:
Don't floor your car at low RPMS, that's incorrect drivng technique.

There, fixed:)
ACtualy im with GLH on tis one as far as not hammering it at very low RPM. You will spike like a mad man.

ACtualy glh, your comment reminds me of the a DR.

DR, my arm hurts when i touch it.

DR says, well dont touch it.

lol!
 

·
Registered
Joined
·
341 Posts
that happened in my car when my ignition wires were going bad...hasnt happened since i replaced them.
 

·
Premium Member
Joined
·
14,830 Posts
To be sure, please define "low RPMS"
 

·
SRTFORUM Moderator
Joined
·
23,153 Posts
hey man, i had a similar problem to mine a while back. Check your TPS sensor, i had a bad wire right by the plug. Shake the wire around, then go drive it. This may help.... it helped me out. hope this helps you... i could be wrong.
 
1 - 10 of 10 Posts
Top