Dodge SRT Forum banner

1 - 20 of 136 Posts

·
Registered
Joined
·
7,982 Posts
Discussion Starter #1
The car is missing a lot of power. The stable is missing abotu 45 horses under it . What bugs me so much is that I thought my car hauled ass only to find this out.
I have a service appointment for Monday morning 7:45. Since its the weekend, and I cant do jack squat, I will put up the dyno sheet.

Normal weather, fan blowing on cool car ;2 back to back, and a third run were done.
Any suggestions on what I can possibly check my self is welcome.
Please lets not make this a bashing or sympathy thread.
I'd like to keep it to serious suggestions, and when they check it out on Monday and hopefully fix it, Ill let u guys know.

Dyno removed for now..I think everyone has seen it, bandwidth aint cheap :(
176WHP
211Tq

Cali
 

·
Super Moderator
Joined
·
6,317 Posts
Is that air/fuel ratio out of whack, or what! Is it normal for it to start that high?
 

·
Registered
Joined
·
2,166 Posts
What kind of Dyno? Can you go to another shop to confirm the numbers?

edit : I just read the other post, hopefully everything checks out at the dealer.
 

·
Registered
Joined
·
1,898 Posts
Try a different brand of gas, mine seems to be very finicky about gas brands, also what gear where your runs in, mine in 1 and 2 is about 2-3 PSI lower than 3-5th.

I am brainstorming for ya, not coming up with much, but i am trying

Steve
 

·
Banned
Joined
·
27,026 Posts
RU every SRT4 runs that rich and no he will not re-dyno until the car has been looked over by Dodge
 

·
Registered
Joined
·
1,223 Posts
Cali,

Have you done ANYTHING at all to the car? Have you "attempted" to put ANY type of boost controller on the car? Any other modifications? Also, have you reset the computer lately? I would recommend that you leave the battery unhooked for at least an hour to make sure.

Give me an IM sometime "SamelCamel" or an email and I'll discuss it with you.

[email protected]
 

·
Registered
Joined
·
3,725 Posts
maybe....

bad gas?...or what octane rating you use?
your car stock completely? you could have really bad fouled plugs.
or a leak in your intercooler piping.

or worst comes to worst, your wastegate is opening earlier than it should causing a loss in hp.
 

·
Registered
Joined
·
1,504 Posts
i would flip dude .. i dont even want to dyno my car , i may kill someone :evil:
 

·
Banned
Joined
·
27,026 Posts
the car is 100% stock except for Turbo Timer and PVO decals...otherwise its 100% stock mechanically
 

·
Registered
Joined
·
7,982 Posts
Discussion Starter #10
Ok ill try to reply to all .
I wished that guys dyno was fucked up but it isnt. He did several other cars that day and all came out within expectation.

93 octane.
Only turbo timer installed.
I looked over the intercooler and it looks fine, just a lil oil deposit on the right side ( when facing car).

I am gonna pull plugs now and check. I know its not a coil pack issue, since I pulled the wires one at a time and they made a difference.
45HORSES is not bad gas, no way in hell am I believing that.

last night at 12AM I took the car out for hard ass runs after resetting the ecu for like 45 minutes. When I came back the exhaust manifold was crimson red. Outside temp was prob in the 60's.

RU... the reason the intial A/f is like that is because, it takes abotu 500 RPMS for the gases to get to the wiedband sensor, since its shoved up the tailpipe.

Cali

EDIT: Plugs are fine. The show signs of running rich thats all.
 

·
Registered
Joined
·
1,898 Posts
What are turning for boost?

Steve
 

·
Banned
Joined
·
27,026 Posts
8 and occasionally a spike to 10
 

·
Registered
Joined
·
1,898 Posts
even in the higher gears? If so, thats your problem,...and the ECU thinks there is some detonation going on (for whatever reason) it backs boost down. Has it always been that low?

STeve
 

·
Registered
Joined
·
1,504 Posts
not good , not good .. damn this car is already being a bitch :evil:
 

·
Registered
Joined
·
1,504 Posts
wait no cel ?? jesus i blow a fuse and the cel comes on.. your car is dying and no cel !!!!
lord help us :cry:
 

·
Registered
Joined
·
7,982 Posts
Discussion Starter #16
stevessrt said:
even in the higher gears? If so, thats your problem,...and the ECU thinks there is some detonation going on (for whatever reason) it backs boost down. Has it always been that low?

STeve
Nope other way around, about 10 in 1 & 2, dropping to 8lbs. IN third shit spikes between 10-15 back and forth. Sometimes it spikes between 15-17 , maybe cuz its trying to make uo for lack of power?
 

·
Banned
Joined
·
27,026 Posts
yeah he hasnt gotten a CEL or anything to indicate any probs. I kept stressing to him the other night when he went to race that Civic that trapped at 104mph and i told him he should have ran better. Now he understands why i was so intent on pointing out the fact SRTs will trap at 100-102mph in the 1320 so he shouldnt have been walked like it went
 

·
Registered
Joined
·
1,898 Posts
Cali said:


Nope other way around, about 10 in 1 & 2, dropping to 8lbs. IN third shit spikes between 10-15 back and forth. Sometimes it spikes between 15-17 , maybe cuz its trying to make uo for lack of power


Does it bounce around like that during the whole acceloration run? Like in 3rd in my car I will hit 13-14PSI, then about 5000rpms it will taper off to 10-12psi.
 

·
Registered
Joined
·
1,898 Posts
I think it has to be either ECU, or wastegate, I know of nobody else getting 17PSI on a stock car, anybody else?
 

·
Registered
Joined
·
7,982 Posts
Discussion Starter #20
stevessrt said:
I think it has to be either ECU, or wastegate, I know of nobody else getting 17PSI on a stock car, anybody else?
Yeap my shit bounces non-stop.
I spoke to sam and he said his holds steady, and now u.

I have checked all the soleniod connections etc, and all hoses are hooked up, so I may have a malfunctioning solenoid thats it not triggering a CEL. In addition to that ECU may be pulling timing to compensate.

Cali
 
1 - 20 of 136 Posts
About this Discussion
135 Replies
40 Participants
RUgoinUp
Dodge SRT Forum
The community to discuss high-performance Dodge vehicles from the SRT and PVO groups, SRT-4, SRT-6, SRT-8, and SRT-10. Come join the fun!
Full Forum Listing
Top