Dodge SRT Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hey im getting a PO340 Code, i was driving down the road and then out of no where the car just died and wouldnt and still wont start back up. Ive changed the crankshaft and camshaft sensor's and now im kinda like wtf do i do now. Anyone have any idea's if so please let me know. Id appreciate any advice. Later
 

·
Registered
Joined
·
587 Posts
Hey im getting a PO340 Code, i was driving down the road and then out of no where the car just died and wouldnt and still wont start back up. Ive changed the crankshaft and camshaft sensor's and now im kinda like wtf do i do now. Anyone have any idea's if so please let me know. Id appreciate any advice. Later
P0340-CAMSHAFT POSITION SENSOR CIRCUIT
I would say check all your wiring
 

·
Registered
Joined
·
12 Posts
I too keep getting the same code. I also changed both camshaft and crankshfat sensor but my car turns on, it just doesn't let me go past 2.5k.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
yeah

Well the problem was that about 8 teeth on the belt about 6 inches long on the belt was wrapped perfectly around the crank shaft and so we had to replace the belt and the car runs great now, so now you know if your car ever dies it may be the belt. Also my car just died on me i didnt have the rev problem that wont get over 2.5k I think i read some where its the PCM has turned the car into Limp home mode or who ever and im not sure ill see if i can find the thread and send it to you. Fu*k i cant get my slave cylinder pushed back in :stab:
 

·
Registered
04 dodge srt4 stage1
Joined
·
93 Posts
Well I guess it's my turn to deal with this... rhe srt4 didnt fire rite up as usual this morn. Was just turning over... tried it again & it fired up , but rh engine lite was on, n the po340 code was showing... Fired right up when I left work, but deff somthin up w it...
 
1 - 6 of 6 Posts
Top