Dodge SRT Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
15,907 Posts
Discussion Starter #1
well im taking the car in tommorow cus this is getting ridiculous...
the problem started when i was coming back to Cali from Phoenix, AZ.
it only happened in 5th at first....i would get on the gas, and it would start to go, then studder, like its choking for air, fuel, or even both....like studdering...
well it went away....then it came back a few days ago....and now tonight, it does it in 2nd, 3rd, 4th, and 5th when i get on it.....especialy when the rpms are at 2k, it will studder and go studder and go.....boosting really low as well, like it pegs at 7psi and wont go any higher....
im thinking fuel pump, fuel filter, or somthing fuel related...
mods are in sig, but im sure none of the mods have to do with the problem...
i also have no CEL.....

sorry if none of this makes sense....i havnt slept in 40 hours...

thanks for any input in advance...

also not even sure if the boost is acurate, i have the infamous broken gauge, but i did the DIY fix by playing with the copper band on the inside till it sits at 0 while the car is off....
 

·
Registered
Joined
·
15,907 Posts
Discussion Starter #3
never....
should that fix the problem?
 

·
Registered
Joined
·
8,246 Posts
definitely plugs/wires
 

·
Registered
Joined
·
15,907 Posts
Discussion Starter #5
been there, done that....
problem solved....


thanks


for now untill i can get some money for the REALLY good stuff...
i just bought some NGK Iradiums gapped them at .40
and some duralast OEM wires....

sputter is gone....
 
1 - 5 of 5 Posts
Top