Dodge SRT Forum banner

1 - 20 of 493 Posts

·
Registered
Joined
·
149 Posts
Discussion Starter #1
ok guys as some of you may know my car has been down since dec same with bitts car.. we couldnt rev past 2300 rpm we both been through hell and back with this stupid thing..

heres the parts ive replaced:

went through 9 CAM sensors
2 crank sensors
wiring harrness
BRAND NEW PCM
have had numerous shops and frds look at it to test wires
^^^ Spent bout $900$ ^^^

SRTGORDO called me and told me it is NOT YOUR TIMMING BELT... it is CAM MAGNET.. so me and bitts went to dealer got magnet cost me $11.52 and my car is fiXed.. :rofl:

so dont waste you money in buying all these parts..

if you have any questions just let one of us know pm us.... Thanks

wickedblk4
bitts
SRTGORDO

we have the answers....:readclose
 

·
Super Moderator
Joined
·
15,302 Posts
Alllow me elaborate.

9 cam sensors from:

-the dealship
-autozone
-o rileys
-advanced auto zone

crank sensor from:
-the dealer

Whole new engine bay harness

Brand new PCM flashed with his VIN

Coil

Wires

Plugs

Went over all the wires possibly related the the CPS

And NO we did not check the timing belt, not needed :readclose

All of these were changed and or replaced.

The FIX:

IMO: If you want the fix for sure get a BRAND NEW cam sensor and a cam sensor magnet from the dealer for the P0344 fix but with the P0340 and P0344 codes replace the crank sensor also, I had luck with that about a year ago.

Be sure to disconnect your battery when putting in the magnet and CPS.
 

·
Super Moderator
Joined
·
15,302 Posts
We will see man, I dont see why not, it was the only part over looked and not changed. You think to your self how is it possible a cam magnet go bad or wear out...but it is possible.
 

·
SRT of the Month
Joined
·
2,065 Posts
ok guys as some of you may know my car has been down since dec same with bitts car.. we couldnt rev past 2300 rpm we both been through hell and back with this stupid thing..

heres the parts ive replaced:

went through 9 CAM sensors
2 crank sensors
wiring harrness
BRAND NEW PCM
have had numerous shops and frds look at it to test wires
^^^ Spent bout $900$ ^^^

SRTGORDO called me and told me it is NOT YOUR TIMMING BELT... it is CAM MAGNET.. so me and bitts went to dealer got magnet cost me $11.52 and my car is fiXed.. :rofl:

so dont waste you money in buying all these parts..

if you have any questions just let one of us know pm us.... Thanks

wickedblk4
bitts
SRTGORDO

we have the answers....:readclose
:hi: i hope this help yall guys please let us know if this fix your problem
 

·
Premium Member
Joined
·
3,298 Posts
i will let you know how it goes on my car working on it in a hour or so!
 

·
Registered
Joined
·
82 Posts
i gotta try this and hopefully my problem will be solved
 

·
Registered
Joined
·
82 Posts
i guess the next question would be is there a how-to to replace the magnet the right way?
 

·
Super Moderator
Joined
·
15,302 Posts
i guess the next question would be is there a how-to to replace the magnet the right way?
All you have to do it take off the two bolts for the CPS (8mm) and then a torx wrench to take the bolt out for the magnet, the magnet has two tabs on the back of it that are off center so they can only go on one way.

Its so easy I can do it blindfolded
 

·
SRTforums Member, SRT of the Month
Joined
·
21,297 Posts
Fuckin awesome!!!


Glad to see the murdered out bitts mobile rollin good now
 

·
SRT of the Month
Joined
·
2,065 Posts
Awesome job Julio(SRTGordo)! This man can figure anything out!
Thanks bro :) after all the testing I finally figured out and now we have 2 more set's running again let me know if ya need some help
 

·
Registered
Joined
·
710 Posts
Thanks bro :) after all the testing I finally figured out and now we have 2 more set's running again let me know if ya need some help
I threw this code about six months ago and had the related symptoms (not being able to rev above 2300 rpms) I got the cam sensor and i just assumed the magnet also, and haven't had the problem since. So hopefully this is the for sure fix. :thumbsup:
 

·
SRT of the Month
Joined
·
2,065 Posts
This is now my 3rd CAM Sensor.... replaced two years back and then again last year... this last week I replaced it and I still have the P0344... I'll try the magnet & maybe post some pics :)

*crosses fingers*
let us know if this work for u please :thumbsup:
 

·
Registered
Joined
·
149 Posts
Discussion Starter #19
If it wasent for SRTGORDO i wouldve taken my ish to the dealer and wouldve paid $95 per hour...:stab:

Julio is the SRT-4 king..


thanks again bro for all your help... :rofl:
 

·
SRT of the Month
Joined
·
2,065 Posts
If it wasent for SRTGORDO i wouldve taken my ish to the dealer and wouldve paid $95 per hour...:stab:

Julio is the SRT-4 king..


thanks again bro for all your help... :rofl:
no problem bro glad your car is running good again :thumbsup:
 
1 - 20 of 493 Posts
Top