Dodge SRT Forum banner

21 - 26 of 26 Posts

·
Registered
05 srt-4 white
Joined
·
149 Posts
Guy hasn't even did a boost leak test and your going way off the basic trouble shooting. Let him check things over it could be a number of different things. But for starters you check for leaks to diagnose problems. In many different ways. Low vacuum could be allot of things as well but once again a pressure test will eliminate boost and any vacuum problems and allot of guess work. Just because one person had one thing happen don't mean it's the same for everyone. Just saying don't give worst case right off the bat. Just saying. Also wga solenoid going out will cause this exact boost pressure issue as well. Not saying its the vacuum problem.
 

·
Registered
Joined
·
791 Posts
And what's that prove??? If you don't wanna give positive help why bother being negative as well.
It's information do with it what you want.

My advice, troubleshoot the low vacuum, then worry about the boost, you will probably fix both at the same time.


But what do i know...


Sent from my SM-G988U using Tapatalk
 

·
Registered
Joined
·
791 Posts
Guy hasn't even did a boost leak test and your going way off the basic trouble shooting. Let him check things over it could be a number of different things. But for starters you check for leaks to diagnose problems. In many different ways. Low vacuum could be allot of things as well but once again a pressure test will eliminate boost and any vacuum problems and allot of guess work. Just because one person had one thing happen don't mean it's the same for everyone. Just saying don't give worst case right off the bat. Just saying. Also wga solenoid going out will cause this exact boost pressure issue as well. Not saying its the vacuum problem.
WGA wont cause a loss of 9 inches of vacuum. It will cause a loss of boost pressure, but so will late timing and burnt valves.


Whats more basic than a solid top and bottom end?

lol.

Sent from my SM-G988U using Tapatalk
 

·
Registered
05 srt-4 white
Joined
·
149 Posts
WGA wont cause a loss of 9 inches of vacuum. It will cause a loss of boost pressure, but so will late timing and burnt valves.


Whats more basic than a solid top and bottom end?

lol.

Sent from my SM-G988U using Tapatalk
Wasn't talking about the wga or vac i was talking about the solenoid witch controls boost pressure. The wga solenoid. Sounds too me like it's stuck open which could cause wga spring pressure boost limit. Like I have said this would not have nothing to do with the vac. Only boost and also the op isn't concerned with the vac. So that is his choice. Why be rude because of his choice.

And also that head looks to me like it had allot of knock going on so there was that as well I'm sure. Monitoring might of helped. Just saying. But hey what does any srt owner know everything right were all pro at internet mechanics. Lmao!!!
 

·
Registered
05 srt-4 white
Joined
·
149 Posts
Hey forum,

new guy here. Couldn't find a thread w/ similar signs, if there is one pls lmk.
Got my srt4 passed down from my brother. Pretty much stock except, intercooler, intake, exhaust and a few things that shouldn't have impact.

Here's what's going on - first, second, third... WOT it only goes to 9 psi, stays there for a sec or two, drops 1 psi and holds at 8. My brother said it used to go 15-19.

Boost gauge looks fine - goes to 0 when car is off, -14 vacuum when idling. Car appears to move fine, except for that lower boost.
Checked and tightened a few connectors. Replaced a hump hose right before BOV (had a crack) - no change.

Any ideas, suggestions and links will be appreciated. Lmk if i missed any info.
Any update on this was just curious if you ever did a boost leak test yet? And was curious what you found out.
 
21 - 26 of 26 Posts
Top