Dodge SRT Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
187 Posts
Discussion Starter #1
Replaced the stock clutch on sunday (03/26/2006) with the ACT Clutch. Due to a annoying "Whine" like a belt whine. Came down to thinking it was the throw-out bearing so I decided to just replace/upgrade with a new clutch with the ACT Clutch. Well before the ACT clutch, the stock clutch was making the whining noise, making a "tack chack chack" sound :lol: (hard to explain), and shaking the whole car when leaving in first gear. Well now since replacing it with the new clutch all it does is the whining noise! Its not long term like it use to be with the stock clutch. Just when its cold, and as soon as I engage the clutch it stops! It only last for about a minute and goes away! The clutch feels good now nice and tight and engauges real well. Just worried about that whining noise.

What do you guys think it is? The fork? Throw-out bearing again? Something not lubed right? I am lost to what it is... '

All replies are appreciated, and hope I explained it best as I can.

Jeff
 

·
Registered
Joined
·
187 Posts
Discussion Starter #3
ptperformance said:
Bearing in the tranny I suspect but without hearing it, it could be the power steering.
It is definitely in the tranny! I even got a stethoscope (sp) and listned and it was coming from the tranny! Whenever I engauge the clutch it stops the whinging noise! This morning I started it up and no whining noise so maybe it just needs more time to break in. I dunno...
 

·
Registered
Joined
·
187 Posts
Discussion Starter #4
:bump:
 
1 - 4 of 4 Posts
Top