Dodge SRT Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Some help please, my Head gasket was recently done less then 100 miles ago. Not saying it isn’t possible to be head gasket.
my coolant resivor had milky coolant coming out of the overflow but don’t run hot or smoke.
 

·
Registered
Joined
·
1,323 Posts
Some help please, my Head gasket was recently done less then 100 miles ago. Not saying it isn’t possible to be head gasket.
my coolant resivor had milky coolant coming out of the overflow but don’t run hot or smoke.
flush the system, run it with some sealant for a little while, then check it with a combustion gas checker..

Sent from my SM-G988U using Tapatalk
 

·
Registered
Joined
·
1 Posts
Some help please, my Head gasket was recently done less then 100 miles ago. Not saying it isn’t possible to be head gasket.
my coolant resivor had milky coolant coming out of the overflow but don’t run hot or smoke.
FWIW, I just had a similar problem. Looked like a Wendy's chocolate frosty when I opened my radiator cap. Oil was not milky.

Ended up pulling the oil cooler, and just leaving it deleted (plugged the coolant lines to the oil cooler, attached the filter to where the cooler used to sit). Flushed the radiator, changed the oil.

Thought I had it fixed, as it was a bit slower to overheat, but it ultimately still overheated. Oil pressure light came on pretty frequently, so my dumb ass thought that the oil was low... added a bunch of oil, ended up blowing massive smoke screen for a mile or so, managed to limp it home. Got a fluid transfer pump from autozone and pulled an embarrassing amount of oil through the dipstick. Got the oil level situation squared away, and the overheating got a bit better, but still would peg the temperature gauge.

Had one brief incident where I blew out a bit of white smoke, but that subsided.

Pretty convinced that I was facing a blown head gasket at this point.

Did a combustion gas test, passed. Did a compression test, 150 psi across all four cylinders. Didn't do a leakdown test.

Now not so sure that my HG was blown, but I was completely baffled.

Fast forward two weeks, and finally my dumb ass has a moment of clarity, so to speak.

Can anyone guess what the problem was?

Thermostat, $7.06 OTD at autozone

Drove fifty miles yesterday, A/C on full blast, engine temperatures were perfect. No oil light. And I am happy that something has finally gone right in my life!! (Not hyperbole).

Hopefully this pathetic tale may be of some help to someone.
 
1 - 3 of 3 Posts
Top