Dodge SRT Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
So after 8 years of storage I am geting my 2005 SRT going again and I have forgotten a lot of stuff that I used to know about this stuff. I am stage2, 3" exhaust, intake, TB, ported intake manifold and aftermarket fuel system (lines, fuel rail, Aeromotive fpr, return line, fb pump hanger and pump) and custome tune. I changed the fluids, added oil to cylinders, changed the fuel pickup filter and fuel filter, cleaned the injectors and replaced the seals on the injectors, replaced the diaphram on the fpr. I started it and it runs fine and drives fine. But I have 2 problems: gas odor in the garage (which goes away when the car is not in the garage) and fuel pressure drop. To address the problems, so far I have replaced the injector seals and the fpr diaphram, as stated above. I have also replaced the charcoal canister (big square thing) and another filter type thing on top of the evap stuff in the rear of the car (sorry don't know what it is, had a replacement sitting here for a while so I threw it in). I have also replaced the gas cap. I added UV dye to the fuel as well and I don't see any leaks with the dye.

For the fuel pressure I have the reference port connected just before the throttle body.
When I power up the fuel pump (the few seconds when you first turn the key to "on") I see 58 psi (57.8-58.2).
Once the power to the pump kicks off the pressure immediately drops to around 45psi (44.9-45.2).
Then it continues to drop about .1 (one tenth) psi every second or two. Eventually going to 0.

When I start the car, at idle (around 855rpm), I see 57.7-57.9 psi, AFR=14.7, and ST trims varying between -5.4 to -3.9, LT trim of -.7. These ST trim values seem to change after a few minutes of running to be centered more around 0.
At 1700 rpm I see 58 psi, 14.7 AFR, -3.1 to +.7 ST trim and -4.6 LT trim.
At 3000 rpm I see 59 psi, 14.3 to 14.9 AFR, -6 to +4 ST trim and -1.5 LT trim.
I assume that this stuff is fine, just mentioning it to provide a little more detail.

So questions:
1. What else could be causing the gas odor ? I checked/replaced everything I could think of.
2. Should the fp be maintained at 58 psi only when the pump is running and then drop 13psi, down to 45psi, once the pump shuts off ?
3. Should it then slowly bleed down to 0 so quickly after that ?

The only things I can think of for the fuel pressure drop are either a bad fuel pump check valve (I assume that it has one), a bad fuel pressure regulator (I read some posts about these things not holding pressure), a leaking or stuck open injector, or some other slow leak in the system that I haven't found yet. Any thoughts ?

Should I replace the fpr ? the injectors ?

Thanks for any help or insights you guys may have. -mike.
 

·
Registered
05 srt-4 white
Joined
·
35 Posts
The factory fpr the one on the side of the pump housing that you put the block off ring on when running a after market fpr. I could be wrong but I believe it also serves as the check valve for fuel pressure. And it has a o ring seal that possibly could be leaking. Just a idea to check.
 

·
Registered
Joined
·
2,639 Posts
58psi with out car running is normal
If you have the regulator connected to the manifold vacuum will pull it to 48 normal

gauge going to 0, bad gauge ?

when drivingand during a pull does it go lean ?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Thanks for the responses. I did read about the stock fpr but I have a full blown dual pump hanger so the stock fpr is a thing of the past for me. Interesting about the pressure. I do have it connected to manifold vacuum but am only slightly under 58psi when idling (not down to 48psi). I don't think the readings are off because I have a liquid filled gauge on the fuel rail and an electronic one on the Areomotive fpr running to the scan gauges. They are pretty close in their readings. My idle is around 855 I think.. I'll have to log it at various engine speeds to see how the pressure changes with vac/boost. I'll get back to you on the driving it part.....still waiting for the registration in the mail so outings are limited until then. Thanks again.
 
1 - 4 of 4 Posts
Top