Dodge SRT Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
749 Posts
Discussion Starter · #1 ·
ok guys i am having trouble again. i am having a really loud hissing noise. it seems like the noise is coming from the nember 3 injector. but i dont know what to do??? i tryed wiggling it but it doesnt move, i was thinking to myself that it might be a bad Oring but i am not 100% sure. i dont notice any drop in performance or anything like that i am still hitting the same boost which is 22psi. is there anyone that has had the same problem or know of the same problem??? and what did you or they do to fix the problem??? by the way i have rc750's. thanks-omar
 

·
Registered
Joined
·
14,904 Posts
Just saw this in another thread. It indicated a bad O-ring.
 

·
Registered
Joined
·
749 Posts
Discussion Starter · #3 ·
yeah thats what i thought i am going to do a switch and see what happens
 

·
Registered
Joined
·
3,839 Posts
omar just pull it in check man shouldnt take too long if the car is cool
 

·
Registered
Joined
·
7,550 Posts
Pull fuel relay, start car, wait until it dies, then play with injectors...
 

·
Registered
Joined
·
749 Posts
Discussion Starter · #7 ·
thank you to all, i am going to work on it tonight all will report when i am done
 

·
Registered
Joined
·
749 Posts
Discussion Starter · #8 · (Edited)
car is fix!!!!!!!!!!!!!!:clap: lol. no more noise it was the o-ring. it looked like it was about to break but no more worries until something eles breaks lol nock on wood lol.
 

·
Registered
Joined
·
3,594 Posts
srt-omar said:
car is fix!!!!!!!!!!!!!!:clap: lol. no more noise it was the o-ring. it looked like it was about to break but no more worries until something eles breaks lol nock on wood lol.
you werent throwinga p0171code by anychance?
 
1 - 10 of 10 Posts
Top