Dodge SRT Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Dies anyone know, or has anyone ever had this issue..

I have a fully charged battery
My headlights, done light, and hazards work.
My mileage shows
But there is ko power to the key cycle.

Is there a fuse that controls power to the ignition switch..


Things I have already checked:
All grounds
Brand new battery
Checked the relays under the hood
Checked the fuses in in the dash in between the door
My fusable link is good.


This is my first srt and I've read plenty to get me this far.

I need some help please
 

·
Premium Member
Joined
·
3,453 Posts
does the radio work? can you cycle the key three times to see if there are any CEL codes activated?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
The radio does not work, and I tried the 3 key cycle. It doesn't do anything. Gauges don't light up, gas indicator doesn't move

When it was last running there were no codes.

I parked it, went inside
Came back out
When I tried to turn it on it hesitated for a moment before it cranked..
In the moment that it didnt start I turned the key back, when I went to re try it made the strangest sound I've ever heard. And and relay of some kind clicked. It flashed "FUSE" across the dash and the next time I cycled the key to try to start it, it was dead. I've never got power back at ignition. I've had a buddy come and double check with the volt meter and everything seemed good.

I have researched all over and no one seems to have had this issue.

Ive recently removed the turbo timer. Nothing changed.

When I went out today to try the 3 key cycle for the first time the door beeped but it went away.
 
1 - 5 of 5 Posts
Top