Dodge SRT Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
New to the SRT community &
boosted cars 🙂well ive had the car for about 2 months it was working perfectly until now , so when ever I floor the car it hesitates for a second then the rpms bounce way too fast but the car doesnt even move. This is with every gear it seems like there isnt even a turbo. Could it be a sensor? Vaccum leak?? … etc…
 

·
Registered
Joined
·
2,198 Posts
New to the SRT community &
boosted cars well ive had the car for about 2 months it was working perfectly until now , so when ever I floor the car it hesitates for a second then the rpms bounce way too fast but the car doesnt even move. This is with every gear it seems like there isnt even a turbo. Could it be a sensor? Vaccum leak?? … etc…
Clutch

Sent from my SM-G988U using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Thats what everyone has told me its like before going into boost the rpms spike all the way to redline and car doesnt move. looks like I will be getting a Southbend stage 2 . Thanks guys!
 

·
Registered
Joined
·
16 Posts
New to the SRT community &
boosted cars 🙂well ive had the car for about 2 months it was working perfectly until now , so when ever I floor the car it hesitates for a second then the rpms bounce way too fast but the car doesnt even move. This is with every gear it seems like there isnt even a turbo. Could it be a sensor? Vaccum leak?? … etc…
Out of curiosity, how long did your clutch last for?
 
1 - 11 of 11 Posts
Top