Dodge SRT Forum banner
21 - 33 of 33 Posts

·
Registered
2004 NSRT4, hx35, 750cc injectors, 255 walbro, ARP headstuds, felpro head gasket, act 6 puck&flywhee
Joined
·
20 Posts
Discussion Starter · #21 ·
clear the codes and try to start it again.. see what happens. yes, check the grounds. make sure you didnt break it when working on the pipe.

Sent from my SM-G988U using Tapatalk
i also looked at my timing and it’s still in line
 

·
Registered
2004 NSRT4, hx35, 750cc injectors, 255 walbro, ARP headstuds, felpro head gasket, act 6 puck&flywhee
Joined
·
20 Posts
Discussion Starter · #23 ·
Buddy something isnt adding up. If you have fuel, Air, spark and timing..physics takes over.. explosions happen whether you want them to or not.

what are you missing?


Sent from my SM-G988U using Tapatalk
all i can think is fuel pressure, that’s the only thing i haven’t confirmed, i think
 

·
Registered
2004 NSRT4, hx35, 750cc injectors, 255 walbro, ARP headstuds, felpro head gasket, act 6 puck&flywhee
Joined
·
20 Posts
Discussion Starter · #24 ·
Buddy something isnt adding up. If you have fuel, Air, spark and timing..physics takes over.. explosions happen whether you want them to or not.

what are you missing?


Sent from my SM-G988U using Tapatalk
i don’t think it’s my compression either, i had it checked less than 500 miles ago and it was 150 across the board
 

·
Registered
2004 NSRT4, hx35, 750cc injectors, 255 walbro, ARP headstuds, felpro head gasket, act 6 puck&flywhee
Joined
·
20 Posts
Discussion Starter · #26 ·
well give that a try. do you hear the pump prime when you turn the key on?

Sent from my SM-G988U using Tapatalk
yes i have a walbro 255 it’s brand new only 50km on it i know that it could still be burnt but we can hear it sucking fuel in the tank
 

·
Registered
2004 NSRT4, hx35, 750cc injectors, 255 walbro, ARP headstuds, felpro head gasket, act 6 puck&flywhee
Joined
·
20 Posts
Discussion Starter · #28 ·
Why so many new parts?

What scantool are you using?

Sent from my SM-G988U using Tapatalk
Previous owner had very poorly put this car together so i have been doing a lot of fixes and new parts. i am just using my diablosport handheld, it’s one of the older ones it’s all i really have right now
 

·
Registered
Joined
·
2,198 Posts
Previous owner had very poorly put this car together so i have been doing a lot of fixes and new parts. i am just using my diablosport handheld, it’s one of the older ones it’s all i really have right now
ahhhhhhhh.. ok. a real scan tool would be very useful.

I wonder what the ECU is seeing, to rule out all kinds of weird stuff

You don't happen to have a oscilloscope do you?

Sent from my SM-G988U using Tapatalk
 

·
Registered
2004 NSRT4, hx35, 750cc injectors, 255 walbro, ARP headstuds, felpro head gasket, act 6 puck&flywhee
Joined
·
20 Posts
Discussion Starter · #30 ·
ahhhhhhhh.. ok. a real scan tool would be very useful.

I wonder what the ECU is seeing, to rule out all kinds of weird stuff

You don't happen to have a oscilloscope do you?

Sent from my SM-G988U using Tapatalk
i can hook up data viewer and select as many PIDS as i can to watch them, but i won’t know what to look for. i’m very unfamiliar with anything to do with tuning
 

·
Registered
2004 NSRT4, hx35, 750cc injectors, 255 walbro, ARP headstuds, felpro head gasket, act 6 puck&flywhee
Joined
·
20 Posts
Discussion Starter · #31 ·
well give that a try. do you hear the pump prime when you turn the key on?

Sent from my SM-G988U using Tapatalk
IT STARTS AGAIN, turns out i was out of fuel! there was enough in the lines to go to the injectors i guess but the sending unit was stuck at half so we had to sri the tank, but we got it and hit everything straightened out again and now i’m back on the road and i have no engine light!

thank you for all the help
 

·
Registered
Joined
·
2,198 Posts
IT STARTS AGAIN, turns out i was out of fuel! there was enough in the lines to go to the injectors i guess but the sending unit was stuck at half so we had to sri the tank, but we got it and hit everything straightened out again and now i’m back on the road and i have no engine light!

thank you for all the help
HAHAHAHAHAH no gas. i knew we were missin something.

Sent from my SM-G988U using Tapatalk
 

·
Registered
2004 NSRT4, hx35, 750cc injectors, 255 walbro, ARP headstuds, felpro head gasket, act 6 puck&flywhee
Joined
·
20 Posts
Discussion Starter · #33 ·
HAHAHAHAHAH no gas. i knew we were missin something.

Sent from my SM-G988U using Tapatalk
Hahahah that’s what everybody has been saying! they’ve all been laughing hahah but that’s fine. gave me an excuse to go over everything on my car and gave me a couple more ideas of things to replace
 
21 - 33 of 33 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top