Dodge SRT Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,251 Posts
Discussion Starter #1
Hey guys just got a new AIT sensor from you guys for your cold side pipe because my old one broke around the brass... On this new one i noticed its different with yellow wires and no resistor. do i still use the old resistor or is this a new one the does not need it.

Mike
 

·
Registered
Joined
·
1,251 Posts
Discussion Starter #2
Bump need to know ASAP!
 

·
Registered
Joined
·
241 Posts
BrooklinSRT4 said:
Hey guys just got a new AIT sensor from you guys for your cold side pipe because my old one broke around the brass... On this new one i noticed its different with yellow wires and no resistor. do i still use the old resistor or is this a new one the does not need it.

Mike
You did receive one of our new AIT sensors which does NOT require a resistor. This new sensor will perform and read just as well as the factory sensor but will not pop out under high boost. Be sure to handle the sensor with care when installing so that you do not pull the wires out from the brass.
 

·
Registered
Joined
·
584 Posts
DodgeSRT4SGP said:
You did receive one of our new AIT sensors which does NOT require a resistor. This new sensor will perform and read just as well as the factory sensor but will not pop out under high boost. Be sure to handle the sensor with care when installing so that you do not pull the wires out from the brass.
Hey Steve, can Jon come and get the new sensor !? :hi:
 

·
Registered
Joined
·
241 Posts
SRT4Jon said:
Hey Steve, can Jon come and get the new sensor !? :hi:
I will have to check with Ben and Kevin on our supply. I think we should be able to, but call me on Monday afternoon and I will find out for sure. I will get you pricing when you call me too. :thumbsup:
 

·
Registered
Joined
·
1,251 Posts
Discussion Starter #7
Awesome... excellent stuff as allways. Thanks
 
1 - 8 of 8 Posts
Top