Dodge SRT Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
371 Posts
Discussion Starter · #1 ·
See my post in the regional...

http://srtforums.com/forums/showthread.php?t=84568

Symptoms: Severe stuttering between 2500 and 3500 rpm's at WOT (feels kinda like fuel cut but not really), Occasional black smoke (only during stuttering)

What they've done in the past that obviously hasn't completely fixed the problem:
1) Replaced all 4 injectors (twice!)
2) Replaced fuel pump kit
3) Replaced plugs and wires
4) Flashed the ECU? (hadn't heard about this being a problem on '04s)


What I've done that obviously hasn't fixed the problem.
1) Replaced the coilpack with the MSD
2) Upgraded to Stage 1

So I guess I take it to the dealership again. I guess I need to get ahold of a lawyer and find out about filing under the lemon law. This shit is starting to seriously piss me off.
So any ideas on what I can try next? Before anybody says reset the pcm, I have.... repeatedly.
 

·
Registered
Joined
·
218 Posts
get rid of the msd pack and go back to the stock one , make sure your wires are making a,
proper connection on the plugs , put some dielectric grease in the boots . what plugs and wires are you running? some sets will pop off the plugs causing your problem.
 

·
Registered
Joined
·
371 Posts
Discussion Starter · #4 ·
SLVRJAY2 said:
get rid of the msd pack and go back to the stock one , make sure your wires are making a,
proper connection on the plugs , put some dielectric grease in the boots . what plugs and wires are you running? some sets will pop off the plugs causing your problem.
Problem exists with either the stock or MSD coilpack, stock or MSD wires, Champions or NGK's........
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top