Dodge SRT Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
459 Posts
Discussion Starter · #1 ·
hey guys, i need some help if possible. today i was driving on my way to school when i came behind this guy and wanted to pass. i was in 4th gear at about 3k rpm's. i down shifted to 3rd and hit about 4500 and heard something pop/blow off (not the bov). next thing i noticed it was all wierd. i coudlnt boost as high as i usually do. i used to spike at 18 and drop to 15, now i spike at 15 and drop to about 11 or 12. so im not boosting as high. also whenever i try to brake i can still brake but i hear this loud noise...a very loud screaming type noise and its like a pulsing kinda like its in one spot on the brakes (or something like that) because it doesnt scream through the whole braking. this is odd. i suspect its something having to do with the vaccum, but then again im not car/turbo expert, so any help would be appreciated
 

·
Registered
Joined
·
4,897 Posts
Check your hoses. Sounds like something popped off and is now rubbing somewhere.

Have you popped your hood yet?
 

·
Premium Member
Joined
·
14,830 Posts
power brake booster line, big black vac line leads into the black dome thing behind the master cylinder on the firewall.
 

·
Registered
Joined
·
459 Posts
Discussion Starter · #5 ·
yes i have looked under the hood and i didnt really know where the solenoids to the vac lines were, also i checked that fat black brake line and didnt see it popped off anywhere, are you sure about this, ill double check it again tonight reguardless
 

·
Registered
Joined
·
604 Posts
if your car is running(idling) and your sitting in it with windows down and hit the brake do you hear a noise?/feel any weird change in idle rpm?

also hrrrrrrrrrm run car for about 35-60 seconds , shut it down , then push down the brake pedal , should be fairly easy to push 1 1/2 - 2 times <--based on vac being present in the booster which is kept in by a check valve , if the pedal is hard (initially should be soft <not spongy of course lol , should get hard after the 1 1/2-2 pumps), there is a prob there.

once you've done this test , pump the pedal a few more times til it's extremely stiff (with the car off) , then , with your foot applying pressure to the hard pedal , start the car , once running , the pedal should drop toward the floor , if this doesn't happen , then you've got a problem there.

don't know if this will help , but it'll rule out a booster and or check valve problem and you can move on to another theory
 

·
Registered
Joined
·
459 Posts
Discussion Starter · #11 ·
ok i did all of what you said and they checked out...no probs there. i got the boost back up to specs, but the brakes are still funny making that loud screaming noise whenever i try to brake. btw, this is only when the car is warmed up
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top