Dodge SRT Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
So I had to replace the engine on my srt 4 and I could only find a pt cruiser engine but my question is why won’t my car start like I replaced the battery and it turned over but after that I got nothing someone please help !!!!!!!
 

·
Super Moderator
Joined
·
16,762 Posts
You are going to need to provide more information here. What year SRT-4? Photos of the engine bay. Are you sure every ground strap and connection is connected.

There are far too many variables here to just assume what is causing the problem.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
You are going to need to provide more information here. What year SRT-4? Photos of the engine bay. Are you sure every ground strap and connection is connected.

There are far too many variables here to just assume what is causing the problem.
So it’s an 05 and as for the photos I’ll send tomorrow I’m at work but yes everything is wired up just lmk what photos you need and I’ll send them because it’s happened before
 

·
Super Moderator
Joined
·
16,762 Posts
Probably fairly detailed of the area with battery and air cleaner removed, just to give people here an idea of what you've got. The SRT is an 05, what about the PT Cruiser? Is the CEL on (check engine light) if so what are the codes?

How long did your car sit without being run, the PL platform cars (Neons/PT Cruisers) are rather notorious for having fuel pumps fail after sitting for awhile.

Does your fuel pump relay kick on when you turn the key on? You should be able to hear it hum when you turn the key to ON, even before you go to START position (cranking).

Getting even more basic, with the internal combustion engine, there are three things needed for the engine to run, that being air, fuel, spark. Have you checked to make sure you are getting fuel when the engine is turning over? You can also pull a spark plug and have a friend help, turn the car over and see if you are getting spark. You may know all this already but I bring it up regardless, I sometimes get in trouble with KISS (Keep It Simple, Stupid) where I waste a LOT of time looking at potential causes that are really difficult and find out it's a really simple issue that I just assumed wouldn't be the problem.

Check the camshaft position sensor and crankshaft sensor.

MAP sensor is another area to look at.

Your ASD (automatic shutdown relay) is another area to look, however an issue here usually has the car starting momentarily then shutting down.

I don't believe this would be anything related to a SKIM (security key) issue, because that causes the car to start for about 2 seconds then immediately shut down.

This will hopefully give you a few areas to look at. There's more obscure ones too, but start checking the easy stuff off your list first, these are some of the easier ones.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top