Dodge SRT Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Having difficulties figuring these codes out. Searched a couple forums but didn’t find any of both u0155 & u110c coming on together. Did a couple pulls and everything was good until the last run, when I shifted to 3rd hard acceleration my car hesitated and started popping.i can cruise normal but once I get on it it will start popping and hesitating. any ideas on what it can be? Everything on the cluster works fine car runs good just on the acceleration part.thanks in advance.....
 

·
Registered
Joined
·
321 Posts
Start by un-hooking your battery

Check the connectors at the PCM
Check ground connector on the block / asd fuse in relay box
Check ground connections around relay box
Check fuses on the side panel driver side
Check aftermarket gauge wiring
Check connection on back of speedo cluster - someone could have swapped it

dodge neon U0155 u110c site:www.srtforums.com
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Start by un-hooking your battery

Check the connectors at the PCM
Check ground connector on the block / asd fuse in relay box
Check ground connections around relay box
Check fuses on the side panel driver side
Check aftermarket gauge wiring
Check connection on back of speedo cluster - someone could have swapped it

dodge neon U0155 u110c site:www.srtforums.com
will do haven’t had time to try anything due to work but have some spare time right now.thank you
 
1 - 3 of 3 Posts
Top