Dodge SRT Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
1,843 Posts
Discussion Starter · #1 ·
sucked

to be fair to me i'm losing a lot of boost with that UPP. i'm gonna check the clamps tomorrow but when you get on the pedal, even reading 0 on the gauge it sounds like a wind tunnel. :( :(

if i cant get it figured out by next weekend the stock pipe goes back on for the track. sorry to disappoint you guys, i feel pretty disappointed myself.

best ET 14.639
best 60' 2.242
best r/t .634 (im working on it!)

best mph 96.18

hopefully that looks bad for a reason and you can say yeah wasp... yer leaking boost all over the track!

the highest boost i got was 10...maybe

i ripped the fucking shift knob off twice. i NEED to change that.

it was still fun but im kinda down about the shitty times. i'll let you know when i figure out what my problem is.
 

·
Super Moderator
‘20 MUSTANG GT/VORTECH SUPERCHARGED/10 SPEED
Joined
·
6,326 Posts
Well at least you got the shifting part down! :lol:

Don't fret, you'll work it all out. :wink:
 

·
Registered
Joined
·
1,843 Posts
Discussion Starter · #4 ·
tomorrow's a new day. i told a friend i'd wait till sunday and check it with him but i cant wait, im gonna look at it tomorrow first thing

me = :cry:
i wanted to get like a 14.1 or flat and be all :):):):) look guys i CAN drive! but alas
 

·
Banned
Joined
·
27,026 Posts
there is a leak...find it!
 

·
Registered
Joined
·
3,028 Posts
Shit dude, hahaha, you're beating that shifter to death! Damn man, I need to get up to Sacramento Raceway and see if I can rip my shift knob off!!! :twisted:
 

·
Registered
Joined
·
1,083 Posts
This was your first time at the track right? It takes practice. My first times weren't too good either.

When you say you hear a wind tunnel at 0 boost, do you mean with your foot on the throttle? That isn't right. I've got the UPP and you should only hear the BOV for a second when you let off on the throttle. Maybe you do have a leak. Check all of your vacuum connections too.

Good luck.
 

·
Registered
Joined
·
1,843 Posts
Discussion Starter · #9 ·
its definately a leak. if you have the upp too it doesnt sound normal.

does yours sound completely normal except for the bov?

right now i'd say when im on the gas and the needle is anywhere from -3 on up it sounds like massive air is coming out somewhere.

i might run sunday just to make myself feel better.
 

·
Registered
Joined
·
1,843 Posts
Discussion Starter · #11 ·
ok well i just went out and looked at it. the rubber part (sleeve?) is almost completely off the intercooler. the only reason i think its still on is the angle that the pipe is in there wouldn't allow it to come off anymore....

here's 2 pics



 

·
Registered
Joined
·
1,843 Posts
Discussion Starter · #13 ·
ok, tightened the clamps down, surprise no more wind tunnel.

for the first time ever im going over 14lbs boost, it spiked to 17 earlier today so i theenk i feexed it.

i REALLY need a shift knob!!!!!!! if someone has some good suggestions please pm me or something!!!!
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top