Dodge SRT Forum banner
1 - 19 of 19 Posts

·
Banned
Joined
·
553 Posts
Discussion Starter · #1 ·
About a week ago I posted saying I discovered that a wiring harness had melted behind my steering wheel due to over wattage from some aftermarket light bulbs I installed. Well after I put the stockers back in and took to a dealership a friend recomended, they replaced everything under warranty. At the time I took my car to the dealership I had the spare tire on the front passanger side. On the drive home from the dealership (i live hour away) I notice at low speeds the car would shake. I dissmissed it as being the spare tire. Well needless to say after putting the new tire back on, the shake got BAD!!!! Next thing I know I'm cussing up and down, beacause my fuck'n axles are BROKE AGAIN!!!! I call the dealership and they say they can't tell me what the problem is untill they look at the car, so they tell me to bring up there and they'll have a look at it and see about getting it fixed.
This is the second time my axles have broke. I willing admit that I broke the first ones. But with the second set I only race on them once, and I didn't wheel hop or anything!!! My car has 35,500 miles on it. So I'm asking ya'll what course of action I should take if they don't cover it under warranty? This actually was the first dealership to cover anything for me under warranty.I should find something out this week.
I ALSO NOTICE THAT THEY PUT FOUR MILES ON MY CAR WHILE THEY HAD IT. I ALSO NOTICE THAT MY SPARE TIRE WAS COMPLETELY BALD WHEN WE PUT THE NEW TIRE ON. SORRY SO LONG........MY RANT IS OVER.
 

·
Registered
Joined
·
41 Posts
Sorry man, i've got nothing to answer that. I've got a question though, you mentioned not racing on the new axles. Is the added stress known to cause problems with them or what? I've never even heard of that being the cause before...then again, i'm much more of a classic guy. I know of rear-end casings coming completely apart but the axle is a rare problem...?
 

·
Registered
Joined
·
891 Posts
That sounds like room for complaint if they put 4 miles on it, sounds like somebody went joy driving and busted an axle just for you.

BTW-spares are not supposed to be used on the drive wheels. This could be why the axle broke but not for sure. I've seen it happen before with a spare on a drive wheel.

Nick :bandit:
 

·
Registered
Joined
·
382 Posts
I like how you admitted your aftermarket bulbs caused the wiring harness meltdown, but went back to stock so you could stick it to the "man" and cause warranty problems for all your other "SRT" brethren...

Also, you admitted that this dealer is the only one that has helped you, and yet you still insist on insulting them by calling them a stealership, when it appears you are the dishonest one, "stealing" from DCX. Not that DCX is perfect, but since when did two wrongs make a right?
 

·
Registered
Joined
·
1,363 Posts
your lucky you dont got an LSD that thing would be dead after driving for 2+ hours on there with a spare... jesus christ man, how old are you? Driving with a spare on a drive wheel... im 18 and a prissy little sheltered dumbass and even I know not to do that.
 

·
SRTForums Member, 2011 Calendar Car
Joined
·
4,118 Posts
Oh puh-lease..... like you guys havent messed up something with aftermarket parts... put the stockers on and went back to the dealer... you know you would do the same thing... You guys make SRT owners look like shit.
 

·
Registered
Joined
·
475 Posts
Cleaned up the thread, stop the personal insults. You've got an opinion fine, you don't have to curse the guy out every other word.
 

·
Registered
Joined
·
4,897 Posts
Troll Hunter said:
Oh puh-lease..... like you guys havent messed up something with aftermarket parts... put the stockers on and went back to the dealer... you know you would do the same thing... You guys make SRT owners look like shit.
I messed up my car and I paid for it! 260 bucks for a 60 dollar part. My fault, my out of pocket expense.
 

·
Banned
Joined
·
553 Posts
Discussion Starter · #17 ·
Troll Hunter said:
Oh puh-lease..... like you guys havent messed up something with aftermarket parts... put the stockers on and went back to the dealer... you know you would do the same thing... You guys make SRT owners look like shit.
Thnks Hunter...damn...this forum has gotten pretty hateful in the last six months. Some of you guys make me want to go buy a civic.
 

·
Registered
Joined
·
4,897 Posts
FWDRacer1838 said:
Thnks Hunter...damn...this forum has gotten pretty hateful in the last six months. Some of you guys make me want to go buy a civic.
Maybe you should, buy a civic that is. People get pretty pissed when thier warranty gets fuxored because of people taking advantage of the system. Thats what you have done.
You raced your car and broke axles which I am sure you had Dodge pay for, then you install bulbs and dont even check to make sure they are the same wattage then fry wires. Return it to stock and have Dodge replace it for something you did wrong.

Its pretty shitty. When I go to the dealer for a legitimet problem that has nothing to do with a mod and my claim gets denied because I have Synthetic oil instead of dyno oil. I will curse your name.
 

·
Registered
Joined
·
1,363 Posts
LowNSlowNeon said:
Oh puh-lease..... like you guys havent messed up something with aftermarket parts... put the stockers on and went back to the dealer... you know you would do the same thing... You guys make SRT owners look like shit.
Actually no I havnt, I am not a pussy about things, if I break it, I pay for it. If you dont have the money to pay for it, dont mod your car. Gotta pay to play.
 
1 - 19 of 19 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top