Dodge SRT Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Ok I’ve been going all over the internet doing some research with my car It’s been throwing the cylinder 4 misfire for quite some time now I’ve Changed

Spark plugs
Plug wires
Camshaft position sensor
The ignition coil
Intake manifold I had a leak from there so I thought that could fix it
I even switched the injectors around and I still get the number 4 misfire
I noticed that when I took off my coil pack with the car running my number 1 and 3 coil pack were sparking a lot but my number 2 and 4 cylinder are sparking so little....

I’ve officially given up and really need some help I don’t know what else to do I’ve put so much money on this car and I’m not tryna get rid of it anytime soon
 

·
Registered
Joined
·
5,756 Posts
What brand of parts did you use? What plugs? When I had a cyl misfire I ended up getting my injectors flow tested and cleaned professionally and put new orings on them. Fixed my misfire issue. When you put a new intake manifold gasket on did you boost leak test the car to make sure it wasn't leaking?

What mods are done your car? Did you look inside your head when you had your intake off for the new gasket on cyl 4? If there is a bunch of carbon build up on your valves that could cause a misfire.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
most of the parts I got were from oriellys I also got ngk plugs it’s about the only brand I use on my cars...and yeah I just yesterday tested my car for boost leaks I found one on my throttle body and one of my lines for the turbo that was torn I feel like I missed some bc my car peaks 18 but drops dramatically to about 13-15 pounds and I tried putting a fuel cleaner on my car o rings were also replaced, mods on the car are only a few suck as aem intake, aftermarket throttle body, stage 2 map, bigger Intercooler, agp wastegate, afr was hooked up but the exhaust burnt the wires before I got it from the last owner he said it was tuned I don’t know much about it... I compression tested every cylinder and they all were around 115-120 I came to find out that my rings were going out and now that u mention it there is carbon build up is there anything I can do bout it?
 

·
Registered
Joined
·
5,756 Posts
NGK 4306 correct? Use only OEM Mopar for coil pack and sensors. the oreillys sensors suck. Research this forum you will find loads of info regarding to only use Mopar sensors. Also lots of threads on misfire issues.

You are on a stock turbo.. They don't like to hold boost. Its normal for that tiny thing to bleed off from 5-6k even with a different WGA.
Aftermarket throttle bodies are junk. Go back to stock. If you are making over 600hp then its time to go with a bigger throttle body. My car had the MPX 62mm TB on it. Only had issues with it. As others have. My tuner, Duster360 told me to get rid of it. Fixed a lot of issues.
So you are running more boost then stock and you cannot monitor AFR's facepalm Get a wideband hooked up ASAP. I wouldn't be going into boost at all until I knew what my AFR's were.
How many miles are on your car?
Is your car on a tune?
How do you know your "rings are going out" ??
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Yes that is correct! Misfire issue is really weird it comes and goes car sounds like it’s running weird but no cel I replaced my cam sensor with my oem on and cleared the code and I’ve been driving it ever since hasn’t come on but the weird thing is I can hear a small miss when the car is idling but thanks for the advice on that I didn’t know that part about sensors.

oh ok I thought it was weird for that to be happening Bc every single one of my lines is ziptied so no boost looks for the time being.
will do I’ll remove the aftermarket TB with a stock one!
I haven’t been hitting boost at all lately yeah it’s tempting but I only use it for work it’s a daily but that’s gonna change soon once I get my new daily.
i ordered a afr gauge 3 days ago it should be here Monday that way I can monitor how lean or rich I’m doing. The car just hit 128000 miles today next weak I’m changing out my timing belt and water pump along with my serpentine belts I don’t know of my car has even had those things done to it so I’m doing it for safety... the guy that I purchased it from told me it was married to a DSP and he had it tuned he didn’t really say much more rather than he bought off the other owner and sold it to me after having it sir for 2 months

i poured bit of oil in each other my cylinders compression went up as high as 170-180
 
1 - 5 of 5 Posts
Top