Dodge SRT Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
109 Posts
Discussion Starter · #1 ·
My car started acting up again last night... It has done this once before, a couple of months after I got it, but then never repeated the problem. I was low on gas (light on but not blinking) and it started to sound bad and run bad whenever I would accelerate.

On the way home from Norman last night it got progressively worse until it sounded really strange at idle and almost didn't want to go whenever I would give it gas. It would just bog and ran really rough. I wound up leaving it on the side of the road at 3am and a friend came and picked my girlfriend and I up. Today I went to it and put a couple gallons in and it started up, ran bad for about 30 seconds, then started running fine again. Last time this happened after I put gas in it ran just fine, but this time when I was driving home and floored it, it would still stumble on and off, but not every time. I just had my fuel pump, spark plugs and #4 plug wire replaced.

I would take it to the dealership but I don't know if I can repeat the problem... maybe I should just replace the fuel filter myself to see if that helps? I don't know, I just want to drive my dam car. :crybaby:
 

·
Registered
Joined
·
642 Posts
what octane gas are you using? aim for 93 if you can and aren't right now. also, reset your PCM...that might help with some of the remaining stuttering
 

·
Registered
Joined
·
294 Posts
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top