Dodge SRT Forum banner
1 - 20 of 72 Posts

·
Premium Member
Joined
·
3,671 Posts
Discussion Starter · #1 ·
Just got off the phone with UniqTwin and she is working hard on a solution for the problem some are haveing with the stalling and not starting problem. There is going to be a meeting tomorrow morning about it, and she asked me to get info for her....

She needs:

Your Name
Address
Phone # ( and best time to contact you )
Name of Dealer you ordered it from
VIN

You can either PM me or send me an e-mail. [email protected]

She is making calls and trying to find out why and how this happend so they can fix it, So please be patient and It will be taken care of ASAP.

Daytona
 

·
Registered
Joined
·
1,037 Posts
Sent ya my info. I put the stock one back in and it works fine starts up with no problems. I plan on taking it to the dealer to make sure everything is ok with the key system thing and the VIN is right. So I hope it works out. If you hear anything call me when you know something.
Thanks,
Lorenzo
 

·
Premium Member
Joined
·
3,671 Posts
Discussion Starter · #3 ·
Uniq will be posting something as soon as posible, Hopefully tomorrow....

Hold on to your stuff till they figure out how to handle it....

They will probebly need to test some of the units to find out what is up...

Each unit is tested to make sure the info is correct, so questions abound, but atleast it is evident that they stand behind there stuff, because if they didn't it would be like " OH WELL, AS IS "

Hang in there,

Daytona
 

·
Registered
Joined
·
21 Posts
This is the difference between a defacto warranty and a written warranty. If we keep records of who and how, Mopar will be obligated to give equal treatment to all customers. That will take precidence over written statements to the contrary.
(It's what you do, not what you say!!)
 

·
Registered
Joined
·
1,037 Posts
Just got back from my dealership just now the VIN wasn't programed into my computer they called and got the pin for the key system and put my VIN in and the car works fine now. Just have to bolt the computer down now but I figured I would let ya know. Thanks
Lorenzo
 

·
Registered
Joined
·
586 Posts
i think it would be interesting to know where you ordered your stage 1 from. could it be that the more that were ordered the more problems there have been? its wierd, when I talked to the parts guy in jacksonville and told him to say the vin back he was like all you need are the last 4 digits. i dont know maybe thats just bs or it could be just a bad flash from where ever they were made.
 

·
Registered
Joined
·
1,037 Posts
I honestly don't know what the deal was I just hope I got a performance computer and not a stock one that wasn't even programed with the new program. I am going to take it for a ride soon. But if u hear anything else let me know. I just want a performance computer. Right now it starts my car but I have yet to test it on the street to make sure I didn't get a stock one.
Lorenzo
 

·
Registered
Joined
·
62 Posts
Just got a call from MOPAR.

They seem to have the issue under control. I should be up and running fairly quickly.

I'll let them post more details, since I don't want to misinform anyone.


Just though I'd let everyone know that they are working hard to resolve the problem.

GOOD JOB MOPAR!

-Chris
 

·
Registered
Joined
·
1,826 Posts
just put mine in and it isn't working. any updates on the fix yet?

:alfdance:
 

·
Registered
Joined
·
62 Posts
Anyone having this issue should PM "Uniq Twin" or call Mopar Electronics at 1-800-866-6727 and ask for Jim Perry.

You'll have to send the units out AT THERE EXPENSE and they'll send them back ASAP.

If you guys have any more questions, drop me a line.

AIM: WSSIX01

or [email protected]

My computer is on its way out already.


-Chris

P.S. Put the stock injectors back in until the new ECU arrives.
 

·
Registered
Joined
·
529 Posts
good thing about waiting is that, most of these problems will be solved by the time i get my srt4. of course i still would rather have mine now. damn credit!!!!!:smoke:
 

·
Registered
Joined
·
48 Posts
TriState Audio said:

You'll have to send the units out AT THERE EXPENSE and they'll send them back ASAP.
Mopar says the same thing; and go as far as stating that no dealer has the gear to enter the VIN, and it MUST be done by them (or their vendor handling that process).

However, at least 3 people on the forum are saying that their local dealership was able to either add or correct the VIN.

What gives? If one dealer can flash with their DRBIII, then ALL dealers can flash with their DRBIII.

It's like kissing your teddy bears good night; when you kiss one, you have too kiss them all.

Or is this another classic case of being kinda pregnant.
 

·
Registered
Joined
·
253 Posts
stage one not work for me

Ok after I installed my stage the car started for about 10 seconds stalled and would not start again unless I took the key out and started it again and then only gets a stall.
So my stage PCM from the vendor was not set up correctly. I think we should get a rebate on the cost we paid for the Stage one when it will not work. I talked to Palmer Dodge in Alpharetta Ga and they will take me Monday morning to redo the PCM. They did Pit Vipers already. They said this is the third one that they will be redoing.
I put the old PCM back on and the car runs fine with the old pcm and new fuel injectors.
Palmer quoted me 80.00 for the redo and said they get right to it and can wait while they do it. If things go right I will have stage one done right Monday...
It took me about 2 hours to install and uninstall and I am really slow at that type work. It was easy to do. Why did Dodge put that side nut/bolt for the bracket, I was tempted to cut it off. I am dissapointed that it would not work the first time. As long as it will work Monday I will be ok with it.
Note : I will be buying a 10 mm socket wrench from Sears this weekend.
:eek:
 
1 - 20 of 72 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top