Dodge SRT Forum banner
1 - 17 of 17 Posts

· Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Everything will be all good while driving normal, but as soon as i get on the gas and the boost starts to build at about 15psi misfires like crazy, and doesnt throw a code or anything. Any clue on whats happening and how i can fix it?
 

· Registered
Joined
·
834 Posts
check spark plugs, wires, then coil pack. i just swapped my coil pack out today cuz i was having the same exact problems. spark plugs were good, wires were on good, so the coil pack was next. and it fixed it. i had an MSD coil for about 12K miles and worked like a champ but lately it started F*ing up at WOT and 15psi+ so i bought a granetelli or however u spell it from MPx and runs alot smoother. definitely get a granetelli coil if u need to replace ur old coil.
 

· Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
thanks, i ordered grantelli wires and ngk iridium plugs last night. Gonna see how that goes. If that doesnt fix it next is my awesome MSD coil pack that was highly recommended :secret:. So i should probably go grantelli coil pack?
 

· Registered
Joined
·
260 Posts
thanks, i ordered grantelli wires and ngk iridium plugs last night. Gonna see how that goes. If that doesnt fix it next is my awesome MSD coil pack that was highly recommended :secret:. So i should probably go grantelli coil pack?
mine was breaking up at about 5+ psi. Just installed the grantelli wires, grantelli coil, and ngk plugs gapped to .032-.038. and All I can say is OMFG. I thought my car was broke after I installed it. I thought I accidentally disconnected the wastgate vac line somehow, but nope. Car runs Amazing now. I also go the heat shield to protect the coil pack.
 

· Registered
Joined
·
1,057 Posts
shit....mine doing the same thing, I know it has to be one of those....I had a pt turbo that once did the same thing, turned out to be a cracked spark plug.....but with the srt, I have a feeling its the msd coil pack....i'll try the spark plug first and I work at a honda dealer and hondas use ngks, so they'll hook me up.
 

· Registered
Joined
·
1,057 Posts
fortunately for me, it turned out to be my spark plugs, bought some ngk plugs, gapped them at .034 each and that fixed it....I've only had my srt for 3 months now and was suprised to see autolite plugs....corroded and one was gapped over .040...but anyway, its fixed.
 

· Premium Member, SRT of the Month
Joined
·
8,314 Posts
thanks, i ordered grantelli wires and ngk iridium plugs last night. Gonna see how that goes. If that doesnt fix it next is my awesome MSD coil pack that was highly recommended :secret:. So i should probably go grantelli coil pack?
You should probably get rid of those iridiums for ngk 4306's.

Oh and I've been running on an msd coil for over 2 years with 400-500hp the whole time.
 
1 - 17 of 17 Posts
Top