Dodge SRT Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
so the car started to run weird, It was shaky and as if it was on cams, came to figure out that I was running on 3 cylinders. I replaced plugs, wires and coils and still had the same issue. I thought I would have a bad compression on one of the cylinders but they all tested out great, I checked the harness on the fuel injectors and they all ready 12V. Now the injectors where after market ones when I got the car, they last guy said he had (1025cc) injectors on a 03 fuel rail (mine is an 04). Anyways I couldn’t find no 1025cc but I found Siemens 80lb injectors, I tried looking up the injectors it had before but the numbers on the injector didn’t help either. I ordered a pack of 4 to changed them but came to realize than maybe some pcm adjustments or something has to happen. Could anybody confirm this or would It be okay to put the new ones right in since everything has already been done and programmed before?
 

·
Registered
Joined
·
1,530 Posts
so the car started to run weird, It was shaky and as if it was on cams, came to figure out that I was running on 3 cylinders. I replaced plugs, wires and coils and still had the same issue. I thought I would have a bad compression on one of the cylinders but they all tested out great, I checked the harness on the fuel injectors and they all ready 12V. Now the injectors where after market ones when I got the car, they last guy said he had (1025cc) injectors on a 03 fuel rail (mine is an 04). Anyways I couldn’t find no 1025cc but I found Siemens 80lb injectors, I tried looking up the injectors it had before but the numbers on the injector didn’t help either. I ordered a pack of 4 to changed them but came to realize than maybe some pcm adjustments or something has to happen. Could anybody confirm this or would It be okay to put the new ones right in since everything has already been done and programmed before?
Coils?

Sent from my SM-G988U using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·

·
Registered
05 srt-4 white
Joined
·
150 Posts
If the adjustments have already been made to the tune for the upgraded injectors then they will be plug n play no further adjustment/scaling will have to made to the tune. This is of course based on the fact of that they are the exact same injectors.
 

·
Registered
Joined
·
152 Posts
ok so you have the same issue I had.

first thing coil pack yes you changed it but to what brand ? these cars are very picky. also make sure the coil pack is plugged in all the way mine was loose and causing issues ,and my timing was off do I fixed the timing .

to then find out the coil wires were bad. make sure they are seated all the way down. and I gapped my 4306 plugs to .30 after that car runs better .
 

·
Registered
Joined
·
152 Posts
my car literally sounded like a Subaru. drove me nuts .

auto zone duralast coils and wires work great. I had an accel yellow coil pack and turns out that thing caused the car to run very funny .
 

·
Registered
Joined
·
4,697 Posts
my car literally sounded like a Subaru. drove me nuts .

auto zone duralast coils and wires work great. I had an accel yellow coil pack and turns out that thing caused the car to run very funny .
I had one of those Accel coil packs briefly in 2003.
Ditched it for a Screamin' Deamon.
A year later, went back to stock coil pack even though the Screamin' was fine.
Been on there since with no problems.
 

·
Registered
Joined
·
152 Posts
I had one of those Accel coil packs briefly in 2003.
Ditched it for a Screamin' Deamon.
A year later, went back to stock coil pack even though the Screamin' was fine.
Been on there since with no problems.
i was shocked whem autozone coils worked
had some from napa there premium coil pack , was junk , installed it missed worse then ever before. as much as people like to make fun of autozone they have the best axles and coils for these cars .
 
1 - 8 of 8 Posts
Top