Dodge SRT Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
246 Posts
Discussion Starter · #1 ·
someone please show me a picture, or how to install the turboxs manual boost controller..i dont know what lines to use or where to accually connect it into, ive tried countless times and it will only boost to 4psi. thanks.
 

·
Premium Member
Joined
·
4,568 Posts
well assuming you have an aftermarket waste gate...

for the original install you should have first capped the black line from the original (stock) wga. Then take the green line off and cap it.

Run one vac line from the waste gate to the back of the turbo (where the green line was originally connected). Tune it to 13psi.

Now run a vac line from the back of the turbo (where the green line was) and run it to the MBC. Then run one more from the MBC to the WGA.

Happy tuning. :cool:
 

·
Registered
Joined
·
246 Posts
Discussion Starter · #5 ·
ive done what you said...and yes ive tried countless times searching. My car will only boost up to 4psi when i capped those lines off, and connected the mbc
 

·
Registered
Joined
·
246 Posts
Discussion Starter · #6 ·
wait, did you say tune the mbc to 13psi? , and also i have an aftermarket BOV , which i heard makes a difference.
 

·
Registered
Joined
·
246 Posts
Discussion Starter · #7 ·
and what would i do if i wanted to use the stock wga to see the difference?
 

·
Mopar Event Specialist
Joined
·
8,584 Posts
You should take the car to someone who knows what they are doing.

At the "Old Farts" bbq last night, a couple of us came to realize what the difference is between our generation, and the latest....

Back then, when we were kids, we took a piece of junk and turned it into something. Nowadays the kids take a something (a new car for example), and turn it into a piece of junk.

At least there will be good project cars for us in the future when the 'tuners' get tired of riding the bus to work... :lol:
 

·
Registered
Joined
·
246 Posts
Discussion Starter · #9 ·
ok, i capped the green line off, and T'd into the wga line, seems to work fine now..
 
1 - 9 of 9 Posts
Top